privoxy actually doesn't require the userid to exist at all. Simply whack the validity checks from configure.in, move PKG_USERS/PKG_GROUPS to the main privoxy package, and all works fine. (Similar to the modifications originally needed for Mailman, but in that case, the numeric user IDs were also embedded in the binaries. Fortunately, that is not the case here.)
62 lines
2.4 KiB
Text
62 lines
2.4 KiB
Text
$NetBSD: patch-ac,v 1.1 2004/09/24 14:08:36 tv Exp $
|
|
|
|
--- configure.in.orig 2004-01-30 04:26:03.000000000 -0500
|
|
+++ configure.in
|
|
@@ -563,29 +563,12 @@ if test "$EMXOS2" = yes; then
|
|
|
|
else
|
|
|
|
- $ID privoxy >/dev/null 2>/dev/null
|
|
- if test $? -ne 0 ; then
|
|
- AC_MSG_WARN(There is no user 'privoxy' on this system)
|
|
- fi
|
|
AC_MSG_CHECKING([for user])
|
|
AC_ARG_WITH(user,
|
|
[ --with-user=privoxy Set user under which privoxy will run],
|
|
[
|
|
- if test "x$withval" != "xyes"; then
|
|
- if test $ID = no ; then
|
|
- AC_MSG_ERROR(There is no 'id' program on this system)
|
|
- else
|
|
AC_MSG_RESULT($with_user)
|
|
- $ID $with_user 2>/dev/null >/dev/null
|
|
- if test $? -eq 0 ; then
|
|
USER=$with_user;
|
|
- else
|
|
- AC_MSG_ERROR(There is no user '$with_user' on this system)
|
|
- fi
|
|
- fi
|
|
- else
|
|
- AC_MSG_ERROR(We need a user if you give me this parameter)
|
|
- fi
|
|
],
|
|
[
|
|
if test $ID = no ; then
|
|
@@ -602,27 +585,8 @@ else
|
|
AC_ARG_WITH(group,
|
|
[ --with-group=privoxy Set group for privoxy],
|
|
[
|
|
- if test "x$withval" != "xyes"; then
|
|
- if test $BGROUPS = no ; then
|
|
- AC_MSG_ERROR(There is no 'groups' program on this system)
|
|
- else
|
|
AC_MSG_RESULT($with_group)
|
|
- $BGROUPS $USER >/dev/null
|
|
- if test $? -eq 0 ; then
|
|
- # FIXME: this fails if valid group, but not first group
|
|
- # listed.
|
|
- if test "$with_group" != "`$BGROUPS $USER | sed 's/.*: //' 2>/dev/null |$AWK '{print $1}'`" ; then
|
|
- AC_MSG_ERROR(The given value '$withval' does not match group entry)
|
|
- else
|
|
GROUP=$with_group;
|
|
- fi
|
|
- else
|
|
- AC_MSG_ERROR(There is no group entry for user '$USER')
|
|
- fi
|
|
- fi
|
|
- else
|
|
- AC_MSG_ERROR(We need a group if you give me this parameter)
|
|
- fi
|
|
],
|
|
[
|
|
if test $BGROUPS = no ; then
|