pkgsrc/databases/py-ldap/patches/patch-aa

48 lines
1.6 KiB
Text

$NetBSD: patch-aa,v 1.1 2003/01/04 18:16:22 cjep Exp $
--- Misc/Makefile.python-1.4.orig Mon Aug 14 23:37:41 2000
+++ Misc/Makefile.python-1.4
@@ -141,6 +141,7 @@ BINLIBDEST= $(LIBDIR)/python$(VERSION)
LIBDEST= $(SCRIPTDIR)/python$(VERSION)
INCLUDEPY= $(INCLUDEDIR)/python$(VERSION)
LIBP= $(exec_installdir)/lib/python$(VERSION)
+DESTSHARED= $(BINLIBDEST)/site-packages
LIBPL= $(LIBP)/config
@@ -159,6 +160,9 @@ SYSLIBS= $(LIBM) $(LIBC)
ADDOBJS= $(LIBPL)/main.o getpath.o config.o
+INSTALL= $(LIBPL)/install-sh -c
+INSTALL_SHARED= ${INSTALL} -m 555
+
# === Fixed rules ===
# Default target. This builds shared libraries only
@@ -249,9 +253,9 @@ sedscript: $(MAKEFILE)
# Bootstrap target
boot: clobber
- VERSION=`python -c "import sys; print sys.version[:3]"`; \
- installdir=`python -c "import sys; print sys.prefix"`; \
- exec_installdir=`python -c "import sys; print sys.exec_prefix"`; \
+ VERSION=`$(PYTHON) -c "import sys; print sys.version[:3]"`; \
+ installdir=`$(PYTHON) -c "import sys; print sys.prefix"`; \
+ exec_installdir=`$(PYTHON) -c "import sys; print sys.exec_prefix"`; \
$(MAKE) -f $(srcdir)/Makefile.pre.in VPATH=$(VPATH) srcdir=$(srcdir) \
VERSION=$$VERSION \
installdir=$$installdir \
@@ -271,3 +275,12 @@ clobber: clean
# Handy target to remove everything you don't want to distribute
distclean: clobber
-rm -f Makefile Setup
+
+install: sharedmods
+ if test ! -d $(DESTSHARED) ; then \
+ mkdir $(DESTSHARED) ; else true ; fi
+ -for i in X $(SHAREDMODS); do \
+ if test $$i != X; \
+ then $(INSTALL_SHARED) $$i $(DESTSHARED)/$$i; \
+ fi; \
+ done