pkgsrc/graphics/gdk-pixbuf/patches/patch-ab
wiz 7fc3179980 Update to 0.22. Remove dependency on auto* by adding patches for the
generated files.

(Not portability) changes since 0.18:
* Made the GIF loader handle animations with frames whose bounds go outside
  of the base image's bounds (Federico).
* Made the GIF loader handle zero-sized frames that GifBuilder and
  similar crap spits sometimes (Federico).
* The PNM loader doesn't abort() anymore if it cannot allocate memory
  (Federico).
* Fixed a g_object_unref() -> gdk_pixbuf_unref() thinko (Federico).
* Merged the patch from Red Hat Linux 8.0 to fix the crash on
  corrupted/short GIFs - Ximian 29040 (patch by Elliot Lee).
* Fixed the RGB 565 LSB -> MSB case in gdk-pixbuf-drawable - 79463
  (Federico).
* Fixed the update region notification in the BMP loader (Federico).
* Merged the BMP loader changes from GTK+ HEAD -- check all reallocs,
  fix 16bpp BI_RGB thinko, properly handle BI_RLE4 and skips and jumps
  (changes by Matthias Clasen).
* Merged the ICO loader changes from GTK+ HEAD (changes by Matthias
  Clasen).
* Merged changes from gtk+/gdk-pixbuf HEAD into the JPEG loader --
  fixes CMYK JPEG problems (changes by Matthias Clasen).
2003-01-15 21:03:25 +00:00

20 lines
500 B
Text

$NetBSD: patch-ab,v 1.3 2003/01/15 21:03:26 wiz Exp $
--- configure.in.orig Thu Apr 18 18:48:40 2002
+++ configure.in
@@ -128,6 +128,7 @@
dnl Check for location of rgb.txt file (works without, but better with)
AC_MSG_CHECKING([for location of rgb.txt database])
+if test -z "$path_rgb_txt"; then
dnl default to this..
path_rgb_txt=/usr/lib/X11/rgb.txt
@@ -140,6 +141,7 @@
break
fi
done
+fi
fi
AC_MSG_RESULT([$path_rgb_txt])
AC_DEFINE_UNQUOTED(PATH_RGB_TXT,"$path_rgb_txt")