pkgsrc/comms/mgetty+sendfax/patches/patch-ab
fredb da1bc56e30 Update to 1.1.30, submitted by Stephane Fortier in PR pkg/22867.
"ChangeLog" since 1.1.28 w/dates and blank lines elided:

	* release 1.1.30
	* voice/vgetty/answer.c, voice/include/default.c: integrate Paul
	Fox' pre_message and beep_sound patches
	* voice/libvoice/detect.c: recognize MultiTech MT3334ZDXV
	* faxhng.c: add some result codes for the i4l DIVA driver
	* voice/libvoice/IS_101.c: fix DTMF events for the unshielded case
	* voice/vgetty/answer.c: accept arbitrary ring types, not only 0..6
	* ring.c: map DRON/DROF return codes to binary word, use result
	  as distinctive RING number
	* frontends/www/README: add user authentication example
	* voice/libvoice/V253modem.c: repair messed-up 16 bit PCM patch

	* release 1.1.29
	* voice/libvoice/detect.c: insert delay before sending ATE0 to
	  modem (timing issue - modem might not have sent the full \r\n
	  sequence from the last "OK" yet when the new AT comes in)
	* doc/*.[158]in: bring man pages up to date
	* tools/ltest.c, tools/mid.c: adapt to new lprintf() prototype
	* mgetty.h, logfile.c: adapt to use <stdarg.h> and "..."
	  function declaration (unless USE_VARARGS is set, which is
	  needed for NeXT platforms).  Karsten Keil <kkeil@suse.de>.
	* Makefile: relax permissions on sendfax and faxrunq.config
	  install - must be readable/executeable by user "fax" now
	* doc/faxrunqd.8in: document "-u", minor updates
	* fax/faxrunqd.in, fax/faxspool.in, fax/faxrunq.in: revert
	  Aug 6, 200 change - put faxqueue_done back into $FAX_SPOOL_OUT/
	  (faxrunq/faxrunqd have no access rights to $VARRUNDIR/ anymore,
	  and $FAX_SPOOL_OUT is no longer world writeable anyway)
	* fax/faxq.in: change from .last_run to faxqueue_done
	* fax/faxrunqd.in: add "-u <user>" switch (set uid to <user>)
	* fax/faxq-helper.c: finalize new fax queue handling using helper
	  process (suid fax) and a fax queue that is no longer
	  world-readable (open issue since 1994 :) )
	* faxrecp.c: implement experimental teergrubing mode (signal
	  "page bad, please retransmit" at the end of each page - or just
	  hang up hard on caller).  Activared with "modem-quirks 0x100"
	  or "0x200", respectively.
	* voice/libvoice/V253Modem.c: add 16 bit linear PCM support
	  (patch coming from Peter Bruley)
	* voice/pvftools/pvftormd.c, rmdtopvf.c: add 16 bit linear PCM
	* rework faxq-helper concept (suid root -> suid fax)
	* fax/faxq.in: adap "-r" to use faxq-helper
	* fax/faxspool.in: adapt to use faxq-helper
	* fax/faxrm.in: adapt to use faxq-helper
	* Makefile: create FAX_SPOOL_OUT with mode 755 and owner FAX_OUT_USER
	* Makefile: add FAX_OUT_USER definition, pass lots of variables
	  to fax/Makefile (for faxq-helper)
	* README.1st: add instructions about FAX_OUT_USER setup
	* doc/mgetty.texi-in add instructions about FAX_OUT_USER setup
	* fax/faxrunqd.in: fix symlink / file overwrite race in JOB files.
	  Pointed out by Jablonovsky Alexander <sasha@cit-saratov.ru>
	* doc/faxrunq.8in: point out insecurity in symlink handling
	* mgetty.h: Intel 64bit platforms (__x86_64__) needs PTR_IS_LONG
	* voice/libvoice/IS_101.c: implement DLE shielding for long DTMF tones
	  for V.253 (initially by Lee Howard <faxguy@howardsilvan.com>)
	* mgetty.c: throw out DIST_RING #define - not used anymore
	* ring.c: make sure action strings (CONNECT) are only recognized
	  at the beginning if a line, not in the middle (Paul Fox,
	  pgf@foxharp.boston.ma.us, CALLER NAME = CONNECTICUT).
	* cnd.c: replace non-printable characters and quotes in caller ID
	  or caller name strings with ' ' - safeguard for passing them to
	  shell later on.
	* doc/mgetty.texi-in: add stuff about recent multitech modems,
	  superfine+v.34 fax, and rework chapter about common problems
	* faxlib.c: fix ugliness with USR modems reporting remote fax
	  ID as "     12345" -> skip leading '"' and all whitespace
	* cnd.c: possible buffer overrun via CallName
	  (found by "A. Guru" <a.guru@sympatico.ca>)
	* fax/faxrunqd: fix priority vs. write combining bug
	* login.c: check for close-on-exec bit on FD 0 (FreeBSD 4.1 bug)
	* login.c: export Caller Name as environment variable $CALLER_NAME
	* login.c: make message about bad permissions even more clear
2003-09-20 16:39:33 +00:00

198 lines
5.9 KiB
Text

$NetBSD: patch-ab,v 1.6 2003/09/20 16:39:38 fredb Exp $
--- Makefile.orig Sun Feb 25 06:33:49 2001
+++ Makefile
@@ -4,8 +4,8 @@
#
# this is the C compiler to use (on SunOS, the standard "cc" does not
# grok my code, so please use gcc there. On ISC 4.0, use "icc".).
-CC=gcc
-#CC=cc
+#CC=gcc
+CC=cc
#
#### C Compiler Flags ####
#
@@ -107,7 +107,7 @@
# prompt first. Don't forget to activate the /AutoPPP/ line in login.config!
#
#CFLAGS=-Wall -O2 -pipe -DSECUREWARE -DUSE_POLL
-CFLAGS=-O2 -Wall -pipe
+CFLAGS+=-DAUTO_PPP -DPREFIX=\"${PREFIX}\"
#CFLAGS=-O -DSVR4
#CFLAGS=-O -DSVR4 -DSVR42
#CFLAGS=-O -DUSE_POLL
@@ -149,7 +149,7 @@
# For Linux, add "-lutil" if the linker complains about "updwtmp".
#
LDFLAGS=
-LIBS=
+LIBS=-lutil
#LIBS=-lprot -lsocket # SCO Unix
#LIBS=-lsocket
#LIBS=-lbsd # OSF/1
@@ -169,15 +169,15 @@
#
# if your systems doesn't have one, use the shell script that I provide
# in "inst.sh" (taken from X11R5). Needed on IRIX5.2
-INSTALL=install -c -o bin -g bin
-#INSTALL=install -c -o root -g wheel # NeXT/BSD
+#INSTALL=install -c -o bin -g bin
+INSTALL=install -c -o root -g wheel # NeXT/BSD
#INSTALL=/usr/ucb/install -c -o bin -g bin # AIX, Solaris 2.x
#INSTALL=installbsd -c -o bin -g bin # OSF/1, AIX 4.1, 4.2
#INSTALL=/usr/bin/X11/bsdinst -c -o bin # IRIX
#
# prefix, where most (all?) of the stuff lives, usually /usr/local or /usr
#
-prefix=/usr/local
+prefix=${PREFIX}
#
# prefix for all the spool directories (usually /usr/spool or /var/spool)
#
@@ -185,20 +185,20 @@
#
# where the mgetty + sendfax binaries live (used for "make install")
#
-SBINDIR=$(prefix)/sbin
+SBINDIR=${PREFIX}/sbin
#
# where the user executable binaries live
#
-BINDIR=$(prefix)/bin
+BINDIR=${PREFIX}/bin
#
# where the font+coverpage files go
#
-LIBDIR=$(prefix)/lib/mgetty+sendfax
+LIBDIR=${PREFIX}/lib/mgetty+sendfax
#
# where the configuration files (*.config, aliases, fax.allow/deny) go to
#
-CONFDIR=$(prefix)/etc/mgetty+sendfax
-#CONFDIR=/etc/default/
+CONFDIR=${MGETTY_CONFDIR}
+CONF_EXAMPLES_DIR=${PREFIX}/share/examples/mgetty+sendfax
#
#
# where mgetty PID files (mgetty.pid) go to
@@ -224,20 +224,20 @@ FAX_OUT_USER=fax
#
#
# Where section 1 manual pages should be placed
-MAN1DIR=$(prefix)/man/man1
+MAN1DIR=${PREFIX}/man/man1
#
# Where section 4 manual pages (mgettydefs.4) should be placed
-MAN4DIR=$(prefix)/man/man4
+MAN4DIR=${PREFIX}/man/man4
#
# Section 5 man pages (faxqueue.5)
-MAN5DIR=$(prefix)/man/man5
+MAN5DIR=${PREFIX}/man/man5
#
# Section 8 man pages (sendfax.8)
-MAN8DIR=$(prefix)/man/man8
+MAN8DIR=${PREFIX}/man/man8
#
# Where the GNU Info-Files are located
#
-INFODIR=$(prefix)/info
+INFODIR=${PREFIX}/info
#
#
# A shell that understands bourne-shell syntax
@@ -254,7 +254,7 @@
# If you have Perl with TK extentions, define it here. This may be the
# same as PERL=... above, or different, if you have TkPerl statically
# linked.
-TKPERL=/usr/bin/tkperl
+#TKPERL=/usr/bin/tkperl
#
#
# An echo program that understands escapes like "\n" for newline or
@@ -266,9 +266,9 @@
# please use the "mg.echo" program provided in the compat/ subdirectory.
# Set ECHO="mg.echo" and INSTALL_MECHO to mg.echo
#
-ECHO="echo"
+ECHO="mg.echo"
#
-# INSTALL_MECHO=mg.echo
+INSTALL_MECHO=mg.echo
#
# for mgetty, that's it. If you want to use the voice
@@ -276,7 +276,7 @@
# To maintain security, I recommend creating a new group for
# users who are allowed to manipulate the recorded voice messages.
-PHONE_GROUP=phone
+PHONE_GROUP=uucp
PHONE_PERMS=770
# Add -DNO_STRSTR to CFLAGS if you don't have strstr().
@@ -308,7 +308,7 @@
all: bin-all doc-all
-bin-all: mgetty sendfax newslock subdirs call-back
+bin-all: mgetty sendfax newslock subdirs call-back vgetty
# a few C files need extra compiler arguments
@@ -559,8 +559,8 @@
# internal: use this to create a "clean" mgetty+sendfax tree
bindist: all doc-all sedscript
-rm -rf bindist
- ./mkidirs bindist$(prefix) bindist$(spool)
- bd=`pwd`/bindist; PATH=`pwd`:"$$PATH" $(MAKE) prefix=$$bd$(prefix) \
+ ./mkidirs bindist${PREFIX}/ bindist$(spool)
+ bd=`pwd`/bindist; PATH=`pwd`:"$$PATH" $(MAKE) prefix=$$bd${PREFIX}/ \
BINDIR=$$bd$(BINDIR) SBINDIR=$$bd$(SBINDIR) \
LIBDIR=$$bd$(LIBDIR) CONFDIR=$$bd$(CONFDIR) \
spool=$$bd$(spool) FAX_SPOOL=$$bd$(FAX_SPOOL) \
@@ -572,7 +572,7 @@
cd bindist; gtar cvvfz mgetty$(MR).$(SR)-bin.tgz *
-install: install.bin install.doc
+install: install.bin install.doc install-vgetty
install.bin: mgetty sendfax newslock \
login.config mgetty.config sendfax.config
@@ -580,7 +580,7 @@
# binaries
#
-test -d $(BINDIR) || ( ./mkidirs $(BINDIR) ; chmod 755 $(BINDIR) )
- $(INSTALL) -m 755 newslock $(BINDIR)
+ $(INSTALL) -s -m 755 newslock $(BINDIR)
-test -d $(SBINDIR) || ( ./mkidirs $(SBINDIR) ; chmod 755 $(SBINDIR) )
-mv -f $(SBINDIR)/mgetty $(SBINDIR)/mgetty.old
@@ -592,18 +592,13 @@
#
test -d $(LIBDIR) || \
( ./mkidirs $(LIBDIR) ; chmod 755 $(LIBDIR) )
- test -d $(CONFDIR) || \
- ( ./mkidirs $(CONFDIR); chmod 755 $(CONFDIR))
- test -f $(CONFDIR)/login.config || \
- $(INSTALL) -o root -m 600 login.config $(CONFDIR)/
- test -f $(CONFDIR)/mgetty.config || \
- $(INSTALL) -o root -m 600 mgetty.config $(CONFDIR)/
- test -f $(CONFDIR)/sendfax.config || \
- $(INSTALL) -o root -m 644 sendfax.config $(CONFDIR)/
- test -f $(CONFDIR)/dialin.config || \
- $(INSTALL) -o root -m 600 dialin.config $(CONFDIR)/
- test -f $(CONFDIR)/faxrunq.config || \
- $(INSTALL) -o root -m 644 faxrunq.config $(CONFDIR)/
+ test -d $(CONF_EXAMPLES_DIR) || \
+ ( ./mkidirs $(CONF_EXAMPLES_DIR); chmod 755 $(CONF_EXAMPLES_DIR))
+ $(INSTALL) -o root -m 600 login.config $(CONF_EXAMPLES_DIR)/
+ $(INSTALL) -o root -m 600 mgetty.config $(CONF_EXAMPLES_DIR)/
+ $(INSTALL) -o root -m 644 sendfax.config $(CONF_EXAMPLES_DIR)/
+ $(INSTALL) -o root -m 600 dialin.config $(CONF_EXAMPLES_DIR)/
+ $(INSTALL) -o root -m 644 faxrunq.config $(CONF_EXAMPLES_DIR)/
#
# test for outdated stuff
#