80bfdc7d0b
snapshot) by Richard Hansen of BBN. Mostly the update is straightforward, with a bit more effort to avoid pthreads. (Threads are not ok because pam modules dlopen opensc, and pam modules are used from nonthreaded programs.) New in 0.13.0; 2012-12-04 * New card driver ePass2003. * OpenPGP card: greatly improved card driver and PKCS#15 emulation; implemented write (pkcs15init) mode; greatly enhanced documentation and tools. * ECDSA keys supported in 'read' and 'write' modes by internal PKCS#15 library, PKCS#11 and tools. * Minidriver in 'write' mode. * SM: secure messaging in GlobalPlatform-SP01 and CW14890 specifications; supported by ePass2003, IAS/ECC and AuthentIC cards; "ACL" and "APDU" modes to trigger secure messaging session; 'local' version of the external secure messaging module. * PKCS#15: support of 'secret-key' PKCS#15 objects support of 'authentication-object' PKCS#15 objects support of 'algReference' common key PKCS#15 attribute support of 'algReference' common key PKCS#15 attribute support of 'subjectName' common public key PKCS#15 attribute * PKCS#11: removed 'onepin' version of pkcs#11 module configuration options to expose slots for PINs and present on-card applications. support GOSTR3410 generate key mechanism * Support of PACE reader. * Remove libltdl reference. * ECDSA supported by MyEID card * New card driver for the SmartCard-HSM, a light-weight hardware security module * New useful commands in 'opensc-explorer' tool: 'find', 'put-data', ... * fixed SIGV issue due to the unsupported public key format * fixes for the number of documentation issues
19 lines
683 B
Text
19 lines
683 B
Text
$NetBSD: patch-aa,v 1.4 2014/03/14 20:49:56 gdt Exp $
|
|
|
|
Disable installation of config file, because pkgsrc installs config
|
|
files as examples.
|
|
|
|
--- etc/Makefile.am.orig 2012-12-04 14:43:40.000000000 +0000
|
|
+++ etc/Makefile.am
|
|
@@ -22,11 +22,3 @@ opensc.conf: opensc.conf.in force
|
|
-e 's|@DEFAULT_SM_MODULE[@]|$(DEFAULT_SM_MODULE)|g' \
|
|
-e 's|@DEBUG_FILE[@]|$(DEBUG_FILE)|g' \
|
|
< $< > $@
|
|
-
|
|
-install-exec-hook: opensc.conf
|
|
- $(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
|
|
- if [ -f "$(DESTDIR)$(sysconfdir)/opensc.conf" ]; then \
|
|
- $(INSTALL_DATA) opensc.conf "$(DESTDIR)$(sysconfdir)/opensc.conf.new"; \
|
|
- else \
|
|
- $(INSTALL_DATA) opensc.conf "$(DESTDIR)$(sysconfdir)/opensc.conf"; \
|
|
- fi
|