V3.2.0 2003/11/28 ================= -Updated source to compile with recent gcc compilers -Pausing mp3/wav/ogg playback releases the sound device -Better mp3 integrity checks. Songs that didn't previously play (or only partly), should now play fine (as in, the bits that are valid) -Fixed a bug that would hang mp3blaster if you'd be in a dir that was deleted meanwhile. -bugfix that could crash mp3blaster after a request to quit (..) -bugfix that failed to redraw screen correctly after operations that required input (such as convert to wav, enter group name, ..) -fixed a bug that could crash mp3blaster on opening oggs when sound device was busy. -Check if the playlist directory actually exists before trying to write a playlist -Added '--repeat/-R' command line option -Applied LIRC support patch from Olgierd Pieczul . Thanks a lot!
199 lines
6.8 KiB
Text
199 lines
6.8 KiB
Text
$NetBSD: patch-ae,v 1.2 2003/12/03 12:31:37 cube Exp $
|
|
|
|
--- nmixer/Makefile.in.orig 2003-11-28 21:07:25.000000000 +0100
|
|
+++ nmixer/Makefile.in
|
|
@@ -63,6 +63,7 @@ CC = @CC@
|
|
CXX = @CXX@
|
|
HAVE_LIB = @HAVE_LIB@
|
|
LIB = @LIB@
|
|
+LIBGETOPT = @LIBGETOPT@
|
|
LIBMPEGSOUND = @LIBMPEGSOUND@
|
|
LIBMYSQL = @LIBMYSQL@
|
|
LIBNMIXER = @LIBNMIXER@
|
|
@@ -83,12 +84,11 @@ VERSION = @VERSION@
|
|
|
|
bin_PROGRAMS = nmixer
|
|
nmixer_SOURCES = main.cc
|
|
-nmixer_DEPENDENCIES = @LIBNMIXER@
|
|
-LDADD = @LIBNMIXER@ @NCURSES_LIBS@
|
|
+nmixer_DEPENDENCIES = @LIBNMIXER@ ../getopt/libgetopt.a
|
|
+LDADD = @LIBNMIXER@ @NCURSES_LIBS@ @LIBGETOPT@
|
|
INCLUDES = -I/usr/include/ncurses -I$(srcdir) -I$(includedir)
|
|
noinst_LIBRARIES = libnmixer.a
|
|
-libnmixer_a_SOURCES = nmixer.cc mixers.cc ossmixer.cc nasmixer.cc nmixer.h getopt.c getopt1.c getopt.h
|
|
-
|
|
+libnmixer_a_SOURCES = nmixer.cc mixers.cc ossmixer.cc nasmixer.cc nmixer.h
|
|
CXXFLAGS = @NAS_CFLAGS@
|
|
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
|
CONFIG_HEADER = ../config.h
|
|
@@ -105,8 +105,7 @@ X_LIBS = @X_LIBS@
|
|
X_EXTRA_LIBS = @X_EXTRA_LIBS@
|
|
X_PRE_LIBS = @X_PRE_LIBS@
|
|
libnmixer_a_LIBADD =
|
|
-libnmixer_a_OBJECTS = nmixer.o mixers.o ossmixer.o nasmixer.o getopt.o \
|
|
-getopt1.o
|
|
+libnmixer_a_OBJECTS = nmixer.o mixers.o ossmixer.o nasmixer.o
|
|
AR = ar
|
|
PROGRAMS = $(bin_PROGRAMS)
|
|
|
|
@@ -128,6 +127,8 @@ DISTFILES = $(DIST_COMMON) $(SOURCES) $(
|
|
|
|
TAR = tar
|
|
GZIP_ENV = --best
|
|
+DEP_FILES = .deps/main.P .deps/mixers.P .deps/nasmixer.P .deps/nmixer.P \
|
|
+.deps/ossmixer.P
|
|
SOURCES = $(libnmixer_a_SOURCES) $(nmixer_SOURCES)
|
|
OBJECTS = $(libnmixer_a_OBJECTS) $(nmixer_OBJECTS)
|
|
|
|
@@ -135,9 +136,9 @@ all: all-redirect
|
|
.SUFFIXES:
|
|
.SUFFIXES: .S .c .cc .o .s
|
|
$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
|
|
- cd $(top_srcdir) && $(AUTOMAKE) --gnu --include-deps nmixer/Makefile
|
|
+ cd $(top_srcdir) && $(AUTOMAKE) --gnu nmixer/Makefile
|
|
|
|
-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
|
+Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status $(BUILT_SOURCES)
|
|
cd $(top_builddir) \
|
|
&& CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
|
|
|
|
@@ -151,9 +152,6 @@ distclean-noinstLIBRARIES:
|
|
|
|
maintainer-clean-noinstLIBRARIES:
|
|
|
|
-.c.o:
|
|
- $(COMPILE) -c $<
|
|
-
|
|
.s.o:
|
|
$(COMPILE) -c $<
|
|
|
|
@@ -224,7 +222,7 @@ TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEP
|
|
awk ' { files[$$0] = 1; } \
|
|
END { for (i in files) print i; }'`; \
|
|
test -z "$(ETAGS_ARGS)$$unique$(LISP)$$tags" \
|
|
- || (cd $(srcdir) && etags -o $$here/TAGS $(ETAGS_ARGS) $$tags $$unique $(LISP))
|
|
+ || (cd $(srcdir) && etags $(ETAGS_ARGS) $$tags $$unique $(LISP) -o $$here/TAGS)
|
|
|
|
mostlyclean-tags:
|
|
|
|
@@ -240,6 +238,11 @@ distdir = $(top_builddir)/$(PACKAGE)-$(V
|
|
subdir = nmixer
|
|
|
|
distdir: $(DISTFILES)
|
|
+ here=`cd $(top_builddir) && pwd`; \
|
|
+ top_distdir=`cd $(top_distdir) && pwd`; \
|
|
+ distdir=`cd $(distdir) && pwd`; \
|
|
+ cd $(top_srcdir) \
|
|
+ && $(AUTOMAKE) --include-deps --build-dir=$$here --srcdir-name=$(top_srcdir) --output-dir=$$top_distdir --gnu nmixer/Makefile
|
|
@for file in $(DISTFILES); do \
|
|
d=$(srcdir); \
|
|
if test -d $$d/$$file; then \
|
|
@@ -250,14 +253,57 @@ distdir: $(DISTFILES)
|
|
|| cp -p $$d/$$file $(distdir)/$$file || :; \
|
|
fi; \
|
|
done
|
|
-getopt.o: getopt.c ../config.h
|
|
-getopt1.o: getopt1.c ../config.h getopt.h
|
|
-main.o: main.cc nmixer.h ../config.h getopt.h
|
|
-mixers.o: mixers.cc nmixer.h ../config.h getopt.h
|
|
-nasmixer.o: nasmixer.cc
|
|
-nmixer.o: nmixer.cc nmixer.h ../config.h getopt.h
|
|
-ossmixer.o: ossmixer.cc nmixer.h ../config.h getopt.h
|
|
|
|
+DEPS_MAGIC := $(shell mkdir .deps > /dev/null 2>&1 || :)
|
|
+
|
|
+-include $(DEP_FILES)
|
|
+
|
|
+mostlyclean-depend:
|
|
+
|
|
+clean-depend:
|
|
+
|
|
+distclean-depend:
|
|
+ -rm -rf .deps
|
|
+
|
|
+maintainer-clean-depend:
|
|
+
|
|
+%.o: %.c
|
|
+ @echo '$(COMPILE) -c $<'; \
|
|
+ $(COMPILE) -Wp,-MD,.deps/$(*F).pp -c $<
|
|
+ @-cp .deps/$(*F).pp .deps/$(*F).P; \
|
|
+ tr ' ' '\012' < .deps/$(*F).pp \
|
|
+ | sed -e 's/^\\$$//' -e '/^$$/ d' -e '/:$$/ d' -e 's/$$/ :/' \
|
|
+ >> .deps/$(*F).P; \
|
|
+ rm .deps/$(*F).pp
|
|
+
|
|
+%.lo: %.c
|
|
+ @echo '$(LTCOMPILE) -c $<'; \
|
|
+ $(LTCOMPILE) -Wp,-MD,.deps/$(*F).pp -c $<
|
|
+ @-sed -e 's/^\([^:]*\)\.o[ ]*:/\1.lo \1.o :/' \
|
|
+ < .deps/$(*F).pp > .deps/$(*F).P; \
|
|
+ tr ' ' '\012' < .deps/$(*F).pp \
|
|
+ | sed -e 's/^\\$$//' -e '/^$$/ d' -e '/:$$/ d' -e 's/$$/ :/' \
|
|
+ >> .deps/$(*F).P; \
|
|
+ rm -f .deps/$(*F).pp
|
|
+
|
|
+%.o: %.cc
|
|
+ @echo '$(CXXCOMPILE) -c $<'; \
|
|
+ $(CXXCOMPILE) -Wp,-MD,.deps/$(*F).pp -c $<
|
|
+ @-cp .deps/$(*F).pp .deps/$(*F).P; \
|
|
+ tr ' ' '\012' < .deps/$(*F).pp \
|
|
+ | sed -e 's/^\\$$//' -e '/^$$/ d' -e '/:$$/ d' -e 's/$$/ :/' \
|
|
+ >> .deps/$(*F).P; \
|
|
+ rm .deps/$(*F).pp
|
|
+
|
|
+%.lo: %.cc
|
|
+ @echo '$(LTCXXCOMPILE) -c $<'; \
|
|
+ $(LTCXXCOMPILE) -Wp,-MD,.deps/$(*F).pp -c $<
|
|
+ @-sed -e 's/^\([^:]*\)\.o[ ]*:/\1.lo \1.o :/' \
|
|
+ < .deps/$(*F).pp > .deps/$(*F).P; \
|
|
+ tr ' ' '\012' < .deps/$(*F).pp \
|
|
+ | sed -e 's/^\\$$//' -e '/^$$/ d' -e '/:$$/ d' -e 's/$$/ :/' \
|
|
+ >> .deps/$(*F).P; \
|
|
+ rm -f .deps/$(*F).pp
|
|
info-am:
|
|
info: info-am
|
|
dvi-am:
|
|
@@ -296,25 +342,25 @@ distclean-generic:
|
|
maintainer-clean-generic:
|
|
mostlyclean-am: mostlyclean-noinstLIBRARIES mostlyclean-compile \
|
|
mostlyclean-binPROGRAMS mostlyclean-tags \
|
|
- mostlyclean-generic
|
|
+ mostlyclean-depend mostlyclean-generic
|
|
|
|
mostlyclean: mostlyclean-am
|
|
|
|
clean-am: clean-noinstLIBRARIES clean-compile clean-binPROGRAMS \
|
|
- clean-tags clean-generic mostlyclean-am
|
|
+ clean-tags clean-depend clean-generic mostlyclean-am
|
|
|
|
clean: clean-am
|
|
|
|
distclean-am: distclean-noinstLIBRARIES distclean-compile \
|
|
- distclean-binPROGRAMS distclean-tags distclean-generic \
|
|
- clean-am
|
|
+ distclean-binPROGRAMS distclean-tags distclean-depend \
|
|
+ distclean-generic clean-am
|
|
|
|
distclean: distclean-am
|
|
|
|
maintainer-clean-am: maintainer-clean-noinstLIBRARIES \
|
|
maintainer-clean-compile maintainer-clean-binPROGRAMS \
|
|
- maintainer-clean-tags maintainer-clean-generic \
|
|
- distclean-am
|
|
+ maintainer-clean-tags maintainer-clean-depend \
|
|
+ maintainer-clean-generic distclean-am
|
|
@echo "This command is intended for maintainers to use;"
|
|
@echo "it deletes files that may require special tools to rebuild."
|
|
|
|
@@ -326,8 +372,9 @@ mostlyclean-compile distclean-compile cl
|
|
maintainer-clean-compile mostlyclean-binPROGRAMS distclean-binPROGRAMS \
|
|
clean-binPROGRAMS maintainer-clean-binPROGRAMS uninstall-binPROGRAMS \
|
|
install-binPROGRAMS tags mostlyclean-tags distclean-tags clean-tags \
|
|
-maintainer-clean-tags distdir info-am info dvi-am dvi check check-am \
|
|
-installcheck-am installcheck install-exec-am install-exec \
|
|
+maintainer-clean-tags distdir mostlyclean-depend distclean-depend \
|
|
+clean-depend maintainer-clean-depend info-am info dvi-am dvi check \
|
|
+check-am installcheck-am installcheck install-exec-am install-exec \
|
|
install-data-am install-data install-am install uninstall-am uninstall \
|
|
all-redirect all-am all installdirs mostlyclean-generic \
|
|
distclean-generic clean-generic maintainer-clean-generic clean \
|