Postgresql upstream does not use libtool. pkgsrc used to change postgresql to use libtool, and this package was written to use the pkgsrc-added libtool support. pkgsrc no longer modifies postgresql to use libtool, so postgis did not build. In addition to backing out all the make-postgis-use-libtool packages, this commit adds a patch to add rpath to the PGSQL_FE_LDFLAGS, which upstream hand constructs from pg_config output. PKGREVISION++, but no change in version or functionality (from the previous state, which also didn't build) intended.
19 lines
749 B
Text
19 lines
749 B
Text
$NetBSD: patch-configure.ac,v 1.1 2011/12/31 17:14:16 gdt Exp $
|
|
|
|
Upstream's configure hand-constructs LDFLAGS from using --libdir, and
|
|
fails to address rpath.
|
|
|
|
To be addressed with upstream by gdt after updating to 1.5.3 and
|
|
understanding better.
|
|
|
|
--- configure.ac.orig 2010-01-29 21:24:24.000000000 +0000
|
|
+++ configure.ac
|
|
@@ -341,7 +341,7 @@ AC_SUBST([PGXSOVERRIDE])
|
|
dnl Note: We don't need the server-side LDFLAGS or CPPFLAGS because we get these from PGXS
|
|
|
|
dnl Extract the linker and include flags for the frontend (for programs that use libpq)
|
|
-PGSQL_FE_LDFLAGS=-L`$PGCONFIG --libdir`" -lpq"
|
|
+PGSQL_FE_LDFLAGS="-L`$PGCONFIG --libdir` -R`$PGCONFIG --libdir` -lpq"
|
|
PGSQL_FE_CPPFLAGS=-I`$PGCONFIG --includedir`
|
|
|
|
AC_SUBST([PGSQL_FE_LDFLAGS])
|