pkgsrc/multimedia/vlc/patches/patch-aa
wiz 70adf8ecec Add casts for amd64, reported by Rhialto.
Fix typos in SUBST_MESSAGE*
Add missing x11.buildlink3.mk.
Remove two files from PLIST, because they are not built on my 3.99.18/i386
test system. Bump PKGREVISION.
2006-04-28 23:16:28 +00:00

16 lines
560 B
Text

$NetBSD: patch-aa,v 1.3 2006/04/28 23:16:29 wiz Exp $
--- modules/misc/network/ipv4.c.orig 2004-05-16 17:44:52.000000000 +0000
+++ modules/misc/network/ipv4.c
@@ -406,7 +406,11 @@ static int OpenUDP( vlc_object_t * p_thi
if( IN_MULTICAST( ntohl(inet_addr(psz_server_addr) ) ) )
{
/* set the time-to-live */
+#ifdef __NetBSD__
+ unsigned char ttl = p_socket->i_ttl;
+#else
int ttl = p_socket->i_ttl;
+#endif
if( ttl < 1 )
{
ttl = config_GetInt( p_this, "ttl" );