8e1edf157f
SDCC is a Free ware , retargettable, optimizing ANSI-C compiler. The current version targets Intel 8051 based MCUs, it can be retargetted for other 8 bit MCUs or PICs. The entire source code for the compiler is distributed under GPL. SDCC used ASXXXX & ASLINK a Free ware, retargettable assembler & linker. HTML docs are in work/*/doc. Note I added a patch from sailer@ife.ee.ethz.ch "asxxxx.diff" for making firmware for the Anchor EZUSB chips. This package tracks sdcc 3.x branch.
16 lines
433 B
Text
16 lines
433 B
Text
$NetBSD: patch-support_makebin_Makefile_in,v 1.1 2013/10/21 15:12:38 ryoon Exp $
|
|
|
|
Actually define all the targets used by the package's upper-level
|
|
makefiles.
|
|
|
|
--- support/makebin/Makefile.in.orig 2007-01-03 21:19:58.000000000 +0000
|
|
+++ support/makebin/Makefile.in
|
|
@@ -10,6 +10,8 @@ include $(top_builddir)/Makefile.common
|
|
|
|
all: $(BIN)
|
|
|
|
+dep: ;
|
|
+
|
|
$(BIN): $(OBJ)
|
|
mkdir -p $(top_builddir)/bin
|
|
$(CC) $(LDFLAGS) -o $(BIN) $(OBJ)
|