pkgsrc/lang/php55/patches/patch-sapi_cgi_Makefile.frag
taca cabdc9fcee Update php55 to 5.5.2.
15 Aug 2013, PHP 5.5.2

- Core:
  . Fixed bug #62691 (solaris sed has no -i switch). (Chris Jones)
  . Fixed bug #61345 (CGI mode - make install don't work). (Michael Heimpold)
  . Fixed bug #61268 (--enable-dtrace leads make to clobber
    Zend/zend_dtrace.d) (Chris Jones)

- DOM:
  . Added flags option to DOMDocument::schemaValidate() and
    DOMDocument::schemaValidateSource(). Added LIBXML_SCHEMA_CREATE flag.
    (Chris Wright)

- Sessions:
  . Implemented strict sessions RFC (https://wiki.php.net/rfc/strict_sessions)
    which protects against session fixation attacks and session collisions.
    (Yasuo Ohgaki)
  . Fixed possible buffer overflow under Windows. Note: Not a security fix.
    (Yasuo)
  . Changed session.auto_start to PHP_INI_PERDIR. (Yasuo)

- Pgsql:
  . Fixed bug #62978 (Disallow possible SQL injections with pg_select()
    /pg_update()/pg_delete()/pg_insert()). (Yasuo)

?? ??? 2013, PHP 5.5.2

- Core:
  . Fixed bug #65372 (Segfault in gc_zval_possible_root when return reference
    fails). (Laruence)
  . Fixed value of FILTER_SANITIZE_FULL_SPECIAL_CHARS constant (previously was
    erroneously set to FILTER_SANITIZE_SPECIAL_CHARS value). (Andrey
    avp200681 gmail com).
  . Fixed bug #65304 (Use of max int in array_sum). (Laruence)
  . Fixed bug #65291 (get_defined_constants() causes PHP to crash in a very
    limited case). (Arpad)

- OPcache:
  . Added opcache.restrict_api configuration directive that may limit
    usage of OPcahce API functions only to patricular script(s). (Dmitry)
  . Added support for glob symbols in blacklist entries (?, *, **).
    (Terry Elison, Dmitry)
  . Fixed bug #65338 (Enabling both php_opcache and php_wincache AVs on
    shutdown). (Dmitry)

- Openssl:
  . Fixed handling null bytes in subjectAltName (CVE-2013-4073).
    (Christian Heimes)

- PDO_mysql:
  . Fixed bug #65299 (pdo mysql parsing errors). (Johannes)

- Phar:
  . Fixed bug #65028 (Phar::buildFromDirectory creates corrupt archives for
    some specific contents). (Stas)

- SOAP:
  . Fixed bug #65018 (SoapHeader problems with SoapServer). (Dmitry)

- SPL:
  . Fixed bug #65328 (Segfault when getting SplStack object Value). (Laruence)
  . Added RecursiveTreeIterator setPostfix and getPostifx methods. (Joshua
    Thijssen)
  . Fixed bug #61697 (spl_autoload_functions returns lambda functions
    incorrectly). (Laruence)

- Streams:
  . Fixed bug #65268 (select() implementation uses outdated tick API). (Anatol)

- Pgsql:
  . Fixed bug #65336 (pg_escape_literal/identifier() scilently returns false).
    (Yasuo)
2013-08-17 13:15:21 +00:00

16 lines
922 B
JavaScript

$NetBSD: patch-sapi_cgi_Makefile.frag,v 1.2 2013/08/17 13:15:21 taca Exp $
--- sapi/cgi/Makefile.frag.orig 2013-08-15 20:42:04.000000000 +0000
+++ sapi/cgi/Makefile.frag
@@ -4,9 +4,9 @@ $(SAPI_CGI_PATH): $(PHP_GLOBAL_OBJS) $(P
$(BUILD_CGI)
install-cgi: $(SAPI_CGI_PATH)
- @echo "Installing PHP CGI binary: $(INSTALL_ROOT)$(bindir)/"
+ @echo "Installing PHP CGI binary: $(INSTALL_ROOT)@CGIDIR@/"
@$(mkinstalldirs) $(INSTALL_ROOT)$(bindir)
- @$(INSTALL) -m 0755 $(SAPI_CGI_PATH) $(INSTALL_ROOT)$(bindir)/$(program_prefix)php-cgi$(program_suffix)$(EXEEXT)
+ @$(INSTALL) -m 0755 $(SAPI_CGI_PATH) $(INSTALL_ROOT)@CGIDIR@/$(program_prefix)php$(program_suffix)$(EXEEXT)
@echo "Installing PHP CGI man page: $(INSTALL_ROOT)$(mandir)/man1/"
@$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man1
@$(INSTALL_DATA) sapi/cgi/php-cgi.1 $(INSTALL_ROOT)$(mandir)/man1/$(program_prefix)php-cgi$(program_suffix).1