For full changes, please refer: http://dev.mysql.com/doc/refman/5.1/en/news-5-1-51.html Here is summary for security fixes: * Security Fix: During evaluation of arguments to extreme-value functions (such as LEAST() and GREATEST()), type errors did not propagate properly, causing the server to crash. (Bug#55826) * Security Fix: The server could crash after materializing a derived table that required a temporary table for grouping. (Bug#55568) * Security Fix: A user-variable assignment expression that is evaluated in a logical expression context can be precalculated in a temporary table for GROUP BY. However, when the expression value is used after creation of the temporary table, it was re-evaluated, not read from the table and a server crash resulted. (Bug#55564) * Security Fix: Pre-evaluation of LIKE predicates during view preparation could cause a server crash. (Bug#54568) * Security Fix: GROUP_CONCAT() and WITH ROLLUP together could cause a server crash. (Bug#54476) * Security Fix: Queries could cause a server crash if the GREATEST() or LEAST() function had a mixed list of numeric and LONGBLOB arguments, and the result of such a function was processed using an intermediate temporary table. (Bug#54461) * Security Fix: Queries with nested joins could cause an infinite loop in the server when used from stored procedures and prepared statements. (Bug#53544) * Security Fix: The PolyFromWKB() function could crash the server when improper WKB data was passed to the function. (Bug#51875)
14 lines
556 B
Text
14 lines
556 B
Text
$NetBSD: patch-ak,v 1.3 2010/10/06 12:37:58 taca Exp $
|
|
|
|
* Add some headers to HEADERS_ABI for building properly.
|
|
|
|
--- include/Makefile.in.orig 2010-09-13 13:46:47.000000000 +0000
|
|
+++ include/Makefile.in
|
|
@@ -397,6 +397,7 @@ BUILT_SOURCES = $(HEADERS_GEN_MAKE) link
|
|
HEADERS_GEN_CONFIGURE = mysql_version.h
|
|
HEADERS_GEN_MAKE = my_config.h
|
|
HEADERS_ABI = mysql.h mysql_com.h mysql_time.h \
|
|
+ mysqld_ername.h mysqld_error.h sql_state.h \
|
|
my_list.h my_alloc.h typelib.h mysql/plugin.h
|
|
|
|
pkginclude_HEADERS = $(HEADERS_ABI) my_dbug.h m_string.h my_sys.h \
|