pkgsrc/lang/objc/patches/patch-aa
dholland 427079a95f 1. Not MAKE_JOBS_SAFE.
2. Use MMFLAGS instead of MFLAGS as the compiler flags make variable.
The latter interacts somewhat poorly with make's own usage of the same
identifier. Do this by SUBST at post-extract time so nothing ever sees
the original form, and adjust patches to match.

Does not build (it cannot parse NetBSD's stdlib.h) but no longer
explodes randomly.
2012-01-03 01:25:28 +00:00

13 lines
340 B
Text

$NetBSD: patch-aa,v 1.2 2012/01/03 01:25:28 dholland Exp $
--- src/objc/Makefile.in.orig 2002-05-18 20:57:50.000000000 +1000
+++ src/objc/Makefile.in
@@ -79,7 +79,7 @@ POSTLINKFILES=\
-$(RM) $*.m
.ym.$(OBJSUFFIX):
- $(YACC) $*.ym
+ $(YACC) -d $*.ym
-$(CP) $(YTABH) $*.h
-$(CP) $(YTABC) $*.m
$(OBJC) -c $(MMFLAGS) $(IFLAGS) $*.m