pkgsrc/games/xtris/patches/patch-aa
2006-12-19 12:40:48 +00:00

57 lines
2.3 KiB
Text

$NetBSD: patch-aa,v 1.4 2006/12/19 12:40:48 rillig Exp $
--- Makefile.orig Fri Jan 25 13:42:54 2002
+++ Makefile
@@ -8,23 +8,27 @@
###################
# change this to your favorite ANSI C compiler
-CC = gcc
+CC? = gcc
# change this to the directory where you want the xtris binaries installed
-BINDIR = /usr/local/bin
+BINDIR = ${PREFIX}/bin
# change this to the directory where you want the xtris manpages installed
-MANDIR = /usr/local/man
+MANDIR = ${PREFIX}/man
# change according to taste and local custom...
-CFLAGS = -O3 -D__USE_FIXED_PROTOTYPES__
+CFLAGS += -D__USE_FIXED_PROTOTYPES__ $(IPV6_CFLAGS)
# on Solaris and similar systems, you'll need to uncomment this:
-# EXTRALIBS = -lnsl -lsocket
-
-# specify X11 libdir if your system needs it
-# XLIBDIR = -L/usr/X11/lib
+EXTRALIBS = $(IPV6_LDFLAGS) $(LIBS) #-lnsl -lsocket
+# specify X11 cflags and libdir if your system needs it
+XCFLAGS = -I${X11BASE}/include -Wl,-R${X11BASE}/lib
+XLIBDIR = -L${X11BASE}/lib
+
+# IPv6 Settings
+IPV6_CFLAGS = #-DINET6 #-I/usr/inet6/include
+IPV6_LDFLAGS = #-L/usr/local/v6/lib -linet6
###########################################################################
## You shouldn't need to change anything past this. ##
@@ -35,7 +39,7 @@
all: xtris xtserv xtbot
xtris: xtris.c
- $(CC) $(CFLAGS) -DXTRISPATH="\"$(BINDIR)\"" xtris.c -o xtris $(XLIBDIR) $(XLIBS) $(EXTRALIBS)
+ $(CC) $(CFLAGS) $(XCFLAGS) -DXTRISPATH="\"$(BINDIR)\"" xtris.c -o xtris $(XLIBDIR) $(XLIBS) $(EXTRALIBS)
xtserv: xtserv.c
$(CC) $(CFLAGS) xtserv.c -o xtserv $(EXTRALIBS)
@@ -60,6 +64,6 @@
rm -f xtris.tar.gz
mv -f Makefile Makefile.local
cp Makefile.dist Makefile
- cd .. ; tar cf xtris/xtris.tar xtris/Makefile xtris/Makefile.dist xtris/README xtris/ChangeLog xtris/COPYING xtris/PROTOCOL xtris/xtris.lsm xtris/xtris.c xtris/xtserv.c xtris/xtbot.c xtris/xtbot.h xtris/decide.c xtris/decide.h xtris/xtris.6 xtris/xtserv.6 xtris/xtbot.6 ; gzip -9 xtris/xtris.tar
+ cd .. ; tar cf xtris/xtris.tar xtris/Makefile xtris/Makefile.dist xtris/README xtris/README.v6 xtris/ChangeLog xtris/COPYING xtris/PROTOCOL xtris/xtris.lsm xtris/xtris.c xtris/xtserv.c xtris/xtbot.c xtris/xtbot.h xtris/decide.c xtris/decide.h xtris/xtris.6 xtris/xtserv.6 xtris/xtbot.6 ; gzip -9 xtris/xtris.tar
mv -f Makefile.local Makefile