1dd7d63e34
Bug: * [SSPCPP-656] - NameID insert logic appears wrong for ODBC Session store * [SSPCPP-657] - Update Windows libraries * [SSPCPP-663] - BOOST autoconf macros break with gcc5 * [SSPCPP-665] - Use of systemd breaks on reboot due to disappearance of /run/shibboleth Improvement: * [SSPCPP-654] - Move fork wait timeout from init script to sysconfig Task: * [SSPCPP-661] - Preparation of 2.5.5 release * [SSPCPP-662] - Set AllowSameVersionUpgrades to 'yes' Version 2.5.4 Bug: * [SSPCPP-612] - Old DiscoveryFeed cache files are not correctly removed * [SSPCPP-616] - SP does not build with C++11 * [SSPCPP-621] - log4shib. RemoteSyslogAppender doesn't work in debian. * [SSPCPP-623] - Attribute mapper interprets attribute name with leading/trailing whitespace * [SSPCPP-624] - Trailing whitespace in authnContextClassRef attribute parsed incorrectly * [SSPCPP-627] - SyslogAppender is not working on windows * [SSPCPP-646] - When triggered by file size limit, native.log does not rotate correctly and logs are missing Improvement: * [SSPCPP-618] - Add support for Amazon Linux 2014.3 via attached patch * [SSPCPP-629] - attribute-map.xml missing "uid" attribute (eduPerson) * [SSPCPP-645] - Adjust ownership of /var/cache/shibboleth in the init script of RPM-based Linux distributions * [SSPCPP-647] - consider not permitting RC4 on back channel queries Task: * [SSPCPP-644] - Release log4shib 1.0.9 * [SSPCPP-648] - Release process for 2.5.4 Version 2.5.3 Bug: * [SSPCPP-578] - Example Apache config uses require valid-user * [SSPCPP-580] - FastCGI programs use libxmltooling but don't link with it * [SSPCPP-584] - Limit on preserved POST data size is not enforced * [SSPCPP-585] - POST data replay in Firefox fails if data contains key "submit" * [SSPCPP-589] - Relative paths in Shibboleth XML catalogs are resolved against /usr/share/xml/opensaml * [SSPCPP-595] - postTemplat.html form submission bug * [SSPCPP-596] - Red Hat init script produces spurious restorecon warning at startup * [SSPCPP-603] - Directory Indexes don't work when using file-based basic auth (ShibCompatValidUser is On) Documentation: * [SSPCPP-591] - Errors partialLogout attribute not documented Improvement: * [SSPCPP-598] - Dynamic metadata provider in SP should avoid unmarshalling non-EntityDescriptor results * [SSPCPP-605] - Rephrase error log lines for AuthnFailed responses Task: * [SSPCPP-609] - Release of 2.5.3
92 lines
3 KiB
Text
92 lines
3 KiB
Text
$NetBSD: patch-configs_Makefile.in,v 1.2 2015/10/23 07:35:08 pettai Exp $
|
|
|
|
Install config and example pkgsrc-ish
|
|
|
|
--- configs/Makefile.in.orig 2015-07-09 09:16:39.000000000 -0700
|
|
+++ configs/Makefile.in 2015-10-20 15:27:28.000000000 -0700
|
|
@@ -354,20 +354,13 @@
|
|
pkgcachedir = $(localstatedir)/cache/@PACKAGE_NAME@
|
|
pkgsysconfdir = $(sysconfdir)/@PACKAGE_NAME@
|
|
pkgsysconf_DATA = \
|
|
- shibd-systemd \
|
|
- shibd-redhat \
|
|
- shibd-amazon \
|
|
- shibd-suse \
|
|
- shibd-debian \
|
|
- shibd-osx.plist \
|
|
apache.config \
|
|
apache2.config \
|
|
apache22.config \
|
|
apache24.config \
|
|
- keygen.sh \
|
|
- metagen.sh \
|
|
upgrade.xsl
|
|
|
|
+EGDIR = @EGDIR@
|
|
|
|
# The config files are installed "special". Unlike the entries in
|
|
# pkgsysconf_DATA, these files are installed as "foo.dist" and only
|
|
@@ -480,16 +475,16 @@
|
|
@$(NORMAL_INSTALL)
|
|
@list='$(pkgsysconf_DATA)'; test -n "$(pkgsysconfdir)" || list=; \
|
|
if test -n "$$list"; then \
|
|
- echo " $(MKDIR_P) '$(DESTDIR)$(pkgsysconfdir)'"; \
|
|
- $(MKDIR_P) "$(DESTDIR)$(pkgsysconfdir)" || exit 1; \
|
|
+ echo " $(MKDIR_P) '$(DESTDIR)$(EGDIR)'"; \
|
|
+ $(MKDIR_P) "$(DESTDIR)$(EGDIR)" || exit 1; \
|
|
fi; \
|
|
for p in $$list; do \
|
|
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
echo "$$d$$p"; \
|
|
done | $(am__base_list) | \
|
|
while read files; do \
|
|
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pkgsysconfdir)'"; \
|
|
- $(INSTALL_DATA) $$files "$(DESTDIR)$(pkgsysconfdir)" || exit $$?; \
|
|
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(EGDIR)'"; \
|
|
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(EGDIR)" || exit $$?; \
|
|
done
|
|
|
|
uninstall-pkgsysconfDATA:
|
|
@@ -538,7 +533,7 @@
|
|
check: check-am
|
|
all-am: Makefile $(DATA)
|
|
installdirs:
|
|
- for dir in "$(DESTDIR)$(pkgsysconfdir)"; do \
|
|
+ for dir in "$(DESTDIR)$(EGDIR)"; do \
|
|
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
|
done
|
|
install: install-am
|
|
@@ -594,7 +589,6 @@
|
|
|
|
install-data-am: install-data-local install-pkgsysconfDATA
|
|
@$(NORMAL_INSTALL)
|
|
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
|
|
install-dvi: install-dvi-am
|
|
|
|
install-dvi-am:
|
|
@@ -720,18 +714,18 @@
|
|
$(mkinstalldirs) $(DESTDIR)$(pkgrundir)
|
|
$(mkinstalldirs) $(DESTDIR)$(pkgcachedir)
|
|
$(mkinstalldirs) $(DESTDIR)$(pkgxmldir)
|
|
- $(mkinstalldirs) $(DESTDIR)$(pkgsysconfdir)
|
|
+ $(mkinstalldirs) $(DESTDIR)$(EGDIR)
|
|
for f in $(BUILTCONFIGFILES); do \
|
|
- if test ! -f $(DESTDIR)${pkgsysconfdir}/$$f; then \
|
|
- $(INSTALL_DATA) $$f $(DESTDIR)${pkgsysconfdir}; \
|
|
+ if test ! -f $(DESTDIR)${EGDIR}/$$f; then \
|
|
+ $(INSTALL_DATA) $$f $(DESTDIR)${EGDIR}; \
|
|
fi; \
|
|
- $(INSTALL_DATA) $$f $(DESTDIR)${pkgsysconfdir}/$$f.dist; \
|
|
+ $(INSTALL_DATA) $$f $(DESTDIR)${EGDIR}/$$f.dist; \
|
|
done
|
|
for f in $(CONFIGFILES); do \
|
|
- if test ! -f $(DESTDIR)${pkgsysconfdir}/$$f; then \
|
|
- $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${pkgsysconfdir}; \
|
|
+ if test ! -f $(DESTDIR)${EGDIR}/$$f; then \
|
|
+ $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${EGDIR}; \
|
|
fi; \
|
|
- $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${pkgsysconfdir}/$$f.dist; \
|
|
+ $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)${EGDIR}/$$f.dist; \
|
|
done
|
|
|
|
install-data-hook:
|