361b373309
XXXTNN package phase is broken on macOS due to app bundling changes. Extensive CMake surgery required. Will fix this in a follow-up commit. New in 6.0: - Modern, consistent look and feel KiCad 6.0 features a refreshed user interface designed to reduce the barriers of entry for new users - Upgraded schematic editing KiCad's schematic editor has received its biggest overhaul ever for version 6.0 - Improved PCB design experience KiCad's PCB editor has had a complete look and feel upgrade The following features are deprecated as of version 6.0: XSLT BOM generation scripts The SWIG Python API
25 lines
1,005 B
Text
25 lines
1,005 B
Text
$NetBSD: patch-kicad_CMakeLists.txt,v 1.1 2022/01/02 19:10:03 tnn Exp $
|
|
|
|
Don't use ${CMAKE_MODULE_PATH} directly as it will be changed
|
|
and contains multiple directories
|
|
|
|
--- kicad/CMakeLists.txt.orig 2021-12-22 13:32:19.000000000 +0000
|
|
+++ kicad/CMakeLists.txt
|
|
@@ -164,7 +164,7 @@ if( APPLE )
|
|
${OSX_BUNDLE_OVERRIDE_PATHS}
|
|
|
|
# do all the work
|
|
- include( ${CMAKE_MODULE_PATH}/BundleUtilities.cmake )
|
|
+ include( ${PROJECT_SOURCE_DIR}/CMakeModules/BundleUtilities.cmake )
|
|
|
|
if ( ${PYTHON_FRAMEWORK_HELPER} )
|
|
# This idea here is to repair anything that fixup_bundle doesn't handle
|
|
@@ -235,7 +235,7 @@ if( APPLE )
|
|
move_to_main_bundle( \"pl_editor.app\" \"Page Layout Editor.app\" )
|
|
|
|
if ( ${PYTHON_FRAMEWORK_HELPER} )
|
|
- include( ${CMAKE_MODULE_PATH}/RefixupMacOS.cmake )
|
|
+ include( ${PROJECT_SOURCE_DIR}/CMakeModules/RefixupMacOS.cmake )
|
|
refix_kicad_bundle(${OSX_BUNDLE_INSTALL_DIR})
|
|
endif( )
|
|
|