pkgsrc/databases/postgresql93/patches/patch-contrib_dblink_Makefile
adam 5b31a204aa Major enhancements in PostgreSQL 9.3 include:
* Add materialized views
* Make simple views auto-updatable
* Add many features for the JSON data type, including operators and functions to extract elements from JSON values
* Implement SQL-standard LATERAL option for FROM-clause subqueries and function calls
* Allow foreign data wrappers to support writes (inserts/updates/deletes) on foreign tables
* Add a Postgres foreign data wrapper to allow access to other Postgres servers
* Add support for event triggers
* Add optional ability to checksum data pages and report corruption
* Prevent non-key-field row updates from blocking foreign key checks
* Greatly reduce System V shared memory requirements
2013-09-10 15:32:32 +00:00

12 lines
409 B
Text

$NetBSD: patch-contrib_dblink_Makefile,v 1.1 2013/09/10 15:32:32 adam Exp $
--- contrib/dblink/Makefile.orig 2013-09-02 20:53:17.000000000 +0000
+++ contrib/dblink/Makefile
@@ -4,7 +4,6 @@ MODULE_big = dblink
OBJS = dblink.o
PG_CPPFLAGS = -I$(libpq_srcdir)
SHLIB_LINK = $(libpq)
-SHLIB_PREREQS = submake-libpq
EXTENSION = dblink
DATA = dblink--1.1.sql dblink--1.0--1.1.sql dblink--unpackaged--1.0.sql