the pkgsrc-wip project. (Take ownership with adrianp's permission.) ===== The dk-milter package is an open source implementation of the DomainKeys sender authentication system proposed by Yahoo!, Inc. It consists of a library that implements the DomainKeys service, and a milter-based filter application that can plug in to the sendmail MTA to provide that service to sufficiently recent sendmail MTAs. An optional asynchronous resolver library is also provided to work around limitations of the basic BIND resolver which comes installed on most systems.
34 lines
1.3 KiB
Text
34 lines
1.3 KiB
Text
$NetBSD: patch-aa,v 1.1.1.1 2005/07/20 19:42:50 tv Exp $
|
|
|
|
--- dk-filter/Makefile.m4.orig 2005-07-20 14:55:01.000000000 -0400
|
|
+++ dk-filter/Makefile.m4
|
|
@@ -4,10 +4,10 @@ include(confBUILDTOOLSDIR`/M4/switch.m4'
|
|
define(`confMT', `TRUE')
|
|
define(`confREQUIRE_LIBSM', `true')
|
|
|
|
-APPENDDEF(`confLIBS', `-lssl -lcrypto')
|
|
+APPENDDEF(`confLIBS', `-lssl -lcrypto @PTHREAD_LDFLAGS@ ')
|
|
dnl Enable and edit these paths as needed:
|
|
-dnl APPENDDEF(`confINCDIRS', `-I/usr/local/ssl/include ')
|
|
-dnl APPENDDEF(`confLIBDIRS', `-L/usr/local/ssl/lib ')
|
|
+APPENDDEF(`confINCDIRS', `-I@SSLBASE@/include -I@PTHREAD@/include ')
|
|
+APPENDDEF(`confLIBDIRS', `-L@SSLBASE@/lib -L@PTHREAD@/lib ')
|
|
|
|
dnl To use the asynchronous resolver library provided, enable this line:
|
|
dnl bldPUSH_SMLIB(`ar')
|
|
@@ -19,12 +19,12 @@ bldPUSH_SMLIB(`sm')
|
|
|
|
dnl Enable these next line if needed to specify the locations of libmilter.a
|
|
dnl and the libmilter include files:
|
|
-dnl APPENDDEF(`confINCDIRS', `-I/usr/local/sendmail/include')
|
|
-dnl APPENDDEF(`confLIBDIRS', `-L/usr/local/sendmail/lib')
|
|
+APPENDDEF(`confINCDIRS', `-I@LMBASE@/include ')
|
|
+APPENDDEF(`confLIBDIRS', `-L@LMBASE@/lib')
|
|
|
|
|
|
dnl Enable for IPv6 support:
|
|
-dnl APPENDDEF(`confENVDEF', `-DNETINET6 ')
|
|
+@INET6@ APPENDDEF(`confENVDEF', `-DNETINET6 ')
|
|
|
|
dnl Compile time options, especially FFRs:
|
|
dnl APPENDDEF(`confENVDEF', `-D_FFR_EXTERNAL_IGNORE_LIST ')
|