b2f04064f4
* New stars.dat format with HD catalog numbers and parallax errors omitted * Added catalog cross indexes for HD and SAO catalogs * Fixed bugs in parsing catalog numbers * Added white dwarf temperatures and spectral types DA, DB, DC, DO, DQ, and DZ * Added handling for partial spectral types where one or both of the subclass and luminosity class are unknown * Permit extended star attributes in .stc files: mesh, texture, rotation elements, semiaxes * Support multiple star systems of any complexity with orbits and barycenters * Changed .stc loader so that a star definition with a duplicate catalog number replaces the previous definition * Made catalog numbers optional in .stc files; stars can be defined without having to create fake catalog numbers * Star colors now chosen based on temperature; either 'classic' and black body colors may be selected * Bound % key to toggle between star color tables * Fixed black holes: infinite radius bug gone, rendered just as a plain black sphere * Added comprehensive catalog of all knows stars within 25 light years of the Sun, including orbits for multiple star systems [More] Changes 1.4.1 * Changed maximum number of eclipse shadows in OpenGL 2.0 path from two to three; if max is exceeded, clamp to three rather than not rendering the shadows at all. * Corrected a bad calculation in ring shadow shaders that caused ring shadows to be drawn in the wrong place. * Windows: Fixed the minimum feature size slider in the locations dialog so it updates in response to all the standard controls. * Added a correct InfoURL for the Moon * Windows: added splash screen with a progress indicator * Corrected a local flashing of the Milky Way brightness. * Now the distance to the galaxy center is displayed, if the observer is located inside the galaxy (Milky Way...). * Eliminated various incorrect Hubble type acronyms in deepsky.dsc that had penetrated the PERL filter. * Updated Titan and Iapetus textures in lores directory * Added lunar elevation map, using Clementine laser altimeter data, merged in the polar regions, with topographic data from Clementine 750 nm oblique and nadir images. * Updated/added Tethys textures in lores, medres and hires directories. * Added locations on Phoebe in satmoons2.ssc, as extracted from USGS/IAU official data. * Added Mesh for Phoebe texture. * Updated Iapetus texture. * Moved locations files from extras into data directory for inclusion in standard package. * Fixed bug where displayed time scale differed from actual time scale after clicking a cel URL. [More] Pkgsrc: * Use options.mk framework to build GLUT, GTK, GNOME, or KDE user interface.
22 lines
508 B
Text
22 lines
508 B
Text
$NetBSD: patch-ac,v 1.4 2006/02/17 23:46:39 adam Exp $
|
|
|
|
--- config.h.in.orig 2006-02-15 22:53:21.000000000 +0100
|
|
+++ config.h.in
|
|
@@ -248,7 +248,7 @@ int res_init(void);
|
|
|
|
|
|
|
|
-#if !defined(HAVE_STRLCAT_PROTO)
|
|
+#if !defined(HAVE_STRLCAT_PROTO) && defined(KDELIBSUFF)
|
|
#ifdef __cplusplus
|
|
extern "C" {
|
|
#endif
|
|
@@ -260,7 +260,7 @@ unsigned long strlcat(char*, const char*
|
|
|
|
|
|
|
|
-#if !defined(HAVE_STRLCPY_PROTO)
|
|
+#if !defined(HAVE_STRLCPY_PROTO) && defined(KDELIBSUFF)
|
|
#ifdef __cplusplus
|
|
extern "C" {
|
|
#endif
|