Add php80 package version 8.0.3 (PHP 8.0.3) with current PHP framework of pkgsrc. PHP is a widely-used open source general-purpose scripting language that is especially suited for web development and can be embedded into HTML. It is modular, and object-oriented. Much of its syntax is borrowed from C, Java and Perl with a couple of unique PHP-specific features thrown in. The language is designed to allow web developers to write dynamically generated pages quickly. PHP 8.0 comes with numerous improvements and new features such as * Union Types * Named Arguments * Match Expressions * Attributes * Constructor Property Promotion * Nullsafe Operator * Weak Maps * Just In Time Compilation * And much much more...
18 lines
949 B
JavaScript
18 lines
949 B
JavaScript
$NetBSD: patch-sapi_cgi_Makefile.frag,v 1.1 2021/03/07 13:41:36 taca Exp $
|
|
|
|
Install to CGI directory.
|
|
|
|
--- sapi/cgi/Makefile.frag.orig 2015-06-23 17:33:33.000000000 +0000
|
|
+++ sapi/cgi/Makefile.frag
|
|
@@ -4,9 +4,9 @@ $(SAPI_CGI_PATH): $(PHP_GLOBAL_OBJS) $(P
|
|
$(BUILD_CGI)
|
|
|
|
install-cgi: $(SAPI_CGI_PATH)
|
|
- @echo "Installing PHP CGI binary: $(INSTALL_ROOT)$(bindir)/"
|
|
+ @echo "Installing PHP CGI binary: $(INSTALL_ROOT)@CGIDIR@/"
|
|
@$(mkinstalldirs) $(INSTALL_ROOT)$(bindir)
|
|
- @$(INSTALL) -m 0755 $(SAPI_CGI_PATH) $(INSTALL_ROOT)$(bindir)/$(program_prefix)php-cgi$(program_suffix)$(EXEEXT)
|
|
+ @$(INSTALL) -m 0755 $(SAPI_CGI_PATH) $(INSTALL_ROOT)@CGIDIR@/$(program_prefix)php$(program_suffix)$(EXEEXT)
|
|
@echo "Installing PHP CGI man page: $(INSTALL_ROOT)$(mandir)/man1/"
|
|
@$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man1
|
|
@$(INSTALL_DATA) sapi/cgi/php-cgi.1 $(INSTALL_ROOT)$(mandir)/man1/$(program_prefix)php-cgi$(program_suffix).1
|