pkgsrc/pkgtools/packagekit/patches/patch-an
jmcneill 43e73f96b4 Import packagekit version 0.4.0. Much work to do.
PackageKit is a system designed to make installing and updating software on
your computer easier. The primary design goal is to unify all the software
graphical tools used in different distributions, and use some of the latest
technology like PolicyKit to make the process suck less.

The actual nuts-and-bolts distro tool (yum, apt, conary, etc) is used by
PackageKit using compiled and scripted helpers. PackageKit isn't meant to
replace these tools, instead providing a common set of abstractions that can
be used by standard GUI and text mode package managers.

PackageKit itself is a system activated daemon called packagekitd. Being
system activated means that it's only being run when the user is using a text
mode or graphical tool, and quits when it's no longer being used. This means
we don't delay the boot sequence or session startup and don't consume memory
when not being used.
2009-01-08 00:21:00 +00:00

54 lines
2.9 KiB
Text

$NetBSD: patch-an,v 1.1.1.1 2009/01/08 00:21:00 jmcneill Exp $
--- configure.ac.orig 2008-12-09 03:22:23.000000000 -0500
+++ configure.ac 2009-01-07 08:03:23.000000000 -0500
@@ -353,6 +353,7 @@
AC_ARG_ENABLE(dummy, AS_HELP_STRING([--enable-dummy],[use the dummy backend]),enable_dummy=$enableval,enable_dummy=yes)
AC_ARG_ENABLE(opkg, AS_HELP_STRING([--enable-opkg],[use the OPKG backend]),enable_opkg=$enableval,enable_opkg=no)
AC_ARG_ENABLE(pisi, AS_HELP_STRING([--enable-pisi],[use the PiSi backend]),enable_pisi=$enableval,enable_pisi=no)
+AC_ARG_ENABLE(pkgsrc, AS_HELP_STRING([--enable-pkgsrc],[use the pkgsrc backend]),enable_pkgsrc=$enableval,enable_pkgsrc=no)
AC_ARG_ENABLE(poldek, AS_HELP_STRING([--enable-poldek],[use the poldek backend]),enable_poldek=$enableval,enable_poldek=no)
AC_ARG_ENABLE(razor, AS_HELP_STRING([--enable-razor],[use the razor backend]),enable_razor=$enableval,enable_razor=no)
AC_ARG_ENABLE(smart, AS_HELP_STRING([--enable-smart],[use the SMART backend]),enable_smart=$enableval,enable_smart=no)
@@ -368,6 +369,7 @@
AM_CONDITIONAL(BACKEND_TYPE_DUMMY, [test x$enable_dummy = xyes], [using dummy backend])
AM_CONDITIONAL(BACKEND_TYPE_OPKG, [test x$enable_opkg = xyes], [using OPKG backend])
AM_CONDITIONAL(BACKEND_TYPE_PISI, [test x$enable_pisi = xyes], [using PiSi backend])
+AM_CONDITIONAL(BACKEND_TYPE_PKGSRC, [test x$enable_pkgsrc = xyes], [using pkgsrc backend])
AM_CONDITIONAL(BACKEND_TYPE_POLDEK, [test x$enable_poldek = xyes], [using poldek backend])
AM_CONDITIONAL(BACKEND_TYPE_RAZOR, [test x$enable_razor = xyes], [using Razor backend])
AM_CONDITIONAL(BACKEND_TYPE_SMART, [test x$enable_smart = xyes], [using SMART backend])
@@ -494,7 +496,7 @@
AC_ARG_WITH([default_backend],
AS_HELP_STRING([--with-default-backend=<option>],
[Default backend to use
- alpm,apt,box,conary,dummy,razor,smart,urpmi,yum,pisi,zypp,opkg (dummy)]))
+ alpm,apt,box,conary,dummy,razor,smart,urpmi,yum,pisi,pkgsrc,zypp,opkg (dummy)]))
# default to a sane option for the installed tool
if test x$with_default_backend = x; then
if test -f /usr/bin/yum ; then
@@ -519,6 +521,8 @@
with_default_backend=urpmi
elif test -f /usr/bin/zypper ; then
with_default_backend=zypp
+ elif test -f /usr/sbin/pkg_add ; then
+ with_default_backend=pkgsrc
else
with_default_backend=dummy
fi
@@ -622,6 +626,7 @@
backends/razor/Makefile
backends/yum/Makefile
backends/pisi/Makefile
+backends/pkgsrc/Makefile
backends/poldek/Makefile
backends/zypp/Makefile
data/Makefile
@@ -678,6 +683,7 @@
OPKG backend: ${enable_opkg}
Razor backend: ${enable_razor}
PiSi backend: ${enable_pisi}
+ pkgsrc backend: ${enable_pkgsrc}
poldek backend: ${enable_poldek}
SMART backend: ${enable_smart}
URPMI backend: ${enable_urpmi}