pkgsrc/graphics/dia/patches/patch-aa
wiz 23ea0ae13a Update dia to 0.97.3, provided by David H. Gutteridge in PR 49954.
dia-0.97.3: 2014-09-05

 * Fix double free with some SVG rendering (regression from Dia 0.97.2)
 * Fixes to cope better with updated versions of Dia's dependencies:
   - don't crash at start-up with ABI breaking GLib 2-36
   - don't assert in cairo 1.12 with invalid arc parameters
   - avoid kerning problems (character overlap) for all Pango versions
   - fix image files to be loadable by libpng16
 * Backport fixes for some seldom crashes and other annoyances, see:
   http://bugzilla.gnome.org/buglist.cgi?product=dia&target_milestone=0.97.3
 * Update translations for Brazilian Portuguese, German, Hungarian,
   Polish, Romanian, Serbian and Slovenian
2015-06-09 08:55:22 +00:00

44 lines
2.4 KiB
Text

$NetBSD: patch-aa,v 1.9 2015/06/09 08:55:23 wiz Exp $
--- configure.orig 2014-09-05 11:08:16.000000000 -0400
+++ configure
@@ -19308,7 +19308,7 @@
if ${am_cv_python_pythondir+:} false; then :
$as_echo_n "(cached) " >&6
else
- am_cv_python_pythondir=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib(0,0,prefix='$PYTHON_PREFIX')" 2>/dev/null ||
+ am_cv_python_pythondir=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib(0,0)" 2>/dev/null ||
echo "$PYTHON_PREFIX/${py_lib}/python$PYTHON_VERSION/site-packages"`
fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_pythondir" >&5
@@ -19326,7 +19326,7 @@
if ${am_cv_python_pyexecdir+:} false; then :
$as_echo_n "(cached) " >&6
else
- am_cv_python_pyexecdir=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib(1,0,prefix='$PYTHON_EXEC_PREFIX')" 2>/dev/null ||
+ am_cv_python_pyexecdir=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib(1,0)" 2>/dev/null ||
echo "${PYTHON_EXEC_PREFIX}/${py_lib}/python${PYTHON_VERSION}/site-packages"`
fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_pyexecdir" >&5
@@ -19420,18 +19420,18 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libpython${PYTHON_VERSION}.a" >&5
$as_echo_n "checking for libpython${PYTHON_VERSION}.a... " >&6; }
- py_config_dir="$py_prefix/$py_lib/python${PYTHON_VERSION}/config"
+ py_config_dir="$py_prefix/lib/python${PYTHON_VERSION}/config"
py_makefile="${py_config_dir}/Makefile"
if test -f "$py_makefile"; then
py_basemodlibs=`sed -n -e 's/^BASEMODLIBS=\(.*\)/\1/p' $py_makefile`
py_other_libs=`sed -n -e 's/^LIBS=\(.*\)/\1/p' $py_makefile`
- if test -e "$PYTHON_PREFIX/${py_lib}/libpython${PYTHON_VERSION}.so"; then
+ if test -e "$PYTHON_PREFIX/lib/libpython${PYTHON_VERSION}.so"; then
PYTHON_LIBS="-L${py_config_dir} -lpython${PYTHON_VERSION} $py_basemodlibs $py_other_libs"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: found" >&5
$as_echo "found" >&6; }
- elif test -e "${py_prefix}/${py_lib}/libpython${PYTHON_VERSION}.a"; then
+ elif test -e "${py_prefix}/lib/libpython${PYTHON_VERSION}.a"; then
PYTHON_LIBS="-L${py_config_dir} -lpython${PYTHON_VERSION} $py_basemodlibs $py_other_libs"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: found" >&5
$as_echo "found" >&6; }