pkgsrc/graphics/netpbm/patches/patch-ab
adam 37f11ea699 Changes 10.35.76:
* Pnmtopng:  -libversion doesn't report level of linked libz.
  It was a modularity violation and caused build failures on
  Mac OS X, because Pnmtopng per se doesn't know about libz --
  it's used by libpng.
* Build: don't fail due to SIGRTMIN, SIGRTMAX being undefined.

Changes 10.35.75:
* palmtopnm: fix for pixel size 16.
* pamscale: fix -reduce.  Introduced in 10.27.
* configure: default to 'none' for Svgalib if it doesn't appear to
  be installed (per 'ldconfig').  Ported from 10.38, released March 2007.

Changes 10.35.74:
* pbmtext: don't crash when font file contains a blank line.
  Fail cleanly.
* ppmtoilbm: fix arithmetic overflow with image dimension
  represented as 16 bit integer.
* pbmpage: fix garbage output.
* pnmhistmap: Fix crash with -width.  Always broken.
* Build: don't fail due to SIGPWR being undefined.
2010-07-13 06:08:23 +00:00

18 lines
543 B
Text

$NetBSD: patch-ab,v 1.21 2010/07/13 06:08:23 adam Exp $
--- converter/other/Makefile.orig 2009-09-18 19:04:37.000000000 +0000
+++ converter/other/Makefile
@@ -135,6 +135,13 @@ all: $(BINARIES) $(SUBDIRS:%=%/all)
include $(SRCDIR)/Makefile.common
+# XXX sparc64 gcc 3.3.x toolchain bug; compile exif.o without optimisation
+ifeq ($(MACHINE),sparc64)
+exif.o: exif.c
+ $(CC) -c $(INCLUDES2) -DNDEBUG \
+ $(CPPFLAGS) $(CFLAGS:-O2=) $(CFLAGS_PERSONAL) $(CADD) -o $@ $<
+endif
+
ifeq ($(NEED_RUNTIME_PATH),Y)
LIBOPTR = -runtime
else