7d313c888d
package as lang/lua51. I've adjusted the depends and switched the PKGNAMEs but these packages are otherwise unchanged. This means that you can't install both at once. There are preliminary patches for that (see tech-pkg) but they aren't quite ready yet. This also doesn't include agc's builtin.mk, although it should be possible to drop it into the lua51 package with only very minor modifications. I don't think the builtin packages will allow having one builtin.mk for both lua51 and lua52, but I'd be happy to be shown wrong about that. Add infrastructure support for Lua module packages (including multiversion support), application packages written in Lua, and a redirecting bl3.mk file for packages that just link Lua in. This is based on the Python infrastructure. The new variable LUA_VERSION_DEFAULT picks which Lua package you get by default; it is set to 52 so as to maintain the status quo. Packages can set LUA_VERSIONS_ACCEPTED and/or LUA_VERSIONS_INCOMPATIBLE. I have found (I think) most or all the packages that don't work with lua51 and will be marking those; I have not tracked down most of the ones that don't work with lua52 yet as I was originally intending to roll back to 5.1 as the default.
53 lines
2.2 KiB
Text
53 lines
2.2 KiB
Text
$NetBSD: patch-aa,v 1.1 2013/10/30 06:18:10 dholland Exp $
|
|
|
|
--- Makefile.orig 2008-08-12 01:40:48.000000000 +0100
|
|
+++ Makefile 2009-12-17 16:36:32.000000000 +0000
|
|
@@ -9,11 +9,11 @@ PLAT= none
|
|
|
|
# Where to install. The installation starts in the src and doc directories,
|
|
# so take care if INSTALL_TOP is not an absolute path.
|
|
-INSTALL_TOP= /usr/local
|
|
+INSTALL_TOP= ${PREFIX}
|
|
INSTALL_BIN= $(INSTALL_TOP)/bin
|
|
INSTALL_INC= $(INSTALL_TOP)/include
|
|
INSTALL_LIB= $(INSTALL_TOP)/lib
|
|
-INSTALL_MAN= $(INSTALL_TOP)/man/man1
|
|
+INSTALL_MAN= $(INSTALL_TOP)/${PKGMANDIR}/man1
|
|
#
|
|
# You probably want to make INSTALL_LMOD and INSTALL_CMOD consistent with
|
|
# LUA_ROOT, LUA_LDIR, and LUA_CDIR in luaconf.h (and also with etc/lua.pc).
|
|
@@ -24,7 +24,7 @@ INSTALL_CMOD= $(INSTALL_TOP)/lib/lua/$V
|
|
# may have to run ranlib on the installed liblua.a (do "make ranlib").
|
|
INSTALL= install -p
|
|
INSTALL_EXEC= $(INSTALL) -m 0755
|
|
-INSTALL_DATA= $(INSTALL) -m 0644
|
|
+#INSTALL_DATA= $(INSTALL) -m 0644
|
|
#
|
|
# If you don't have install you can use cp instead.
|
|
# INSTALL= cp -p
|
|
@@ -43,7 +43,7 @@ PLATS= aix ansi bsd freebsd generic linu
|
|
# What to install.
|
|
TO_BIN= lua luac
|
|
TO_INC= lua.h luaconf.h lualib.h lauxlib.h ../etc/lua.hpp
|
|
-TO_LIB= liblua.a
|
|
+TO_LIB= liblua.la
|
|
TO_MAN= lua.1 luac.1
|
|
|
|
# Lua version and release.
|
|
@@ -59,11 +59,11 @@ test: dummy
|
|
src/lua test/hello.lua
|
|
|
|
install: dummy
|
|
- cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
|
|
- cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
|
|
- cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
|
|
- cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
|
|
- cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
|
|
+ cd src && $(MKDIR) $(DESTDIR)$(INSTALL_BIN) $(DESTDIR)$(INSTALL_INC) $(DESTDIR)$(INSTALL_LIB) $(DESTDIR)$(INSTALL_MAN) $(DESTDIR)$(INSTALL_LMOD) $(DESTDIR)$(INSTALL_CMOD)
|
|
+ cd src && $(LIBTOOL) --tag=CC --mode=install $(BSD_INSTALL_PROGRAM) $(TO_BIN) $(DESTDIR)$(INSTALL_BIN)
|
|
+ cd src && $(INSTALL_DATA) $(TO_INC) $(DESTDIR)$(INSTALL_INC)
|
|
+ cd src && $(LIBTOOL) --tag=CC --mode=install $(BSD_INSTALL_LIB) $(TO_LIB) $(DESTDIR)$(INSTALL_LIB)
|
|
+ cd doc && $(INSTALL_DATA) $(TO_MAN) $(DESTDIR)$(INSTALL_MAN)
|
|
|
|
ranlib:
|
|
cd src && cd $(INSTALL_LIB) && $(RANLIB) $(TO_LIB)
|