pkgsrc/databases/postgresql93/patches/patch-src_pl_plperl_GNUmakefile
adam 5b31a204aa Major enhancements in PostgreSQL 9.3 include:
* Add materialized views
* Make simple views auto-updatable
* Add many features for the JSON data type, including operators and functions to extract elements from JSON values
* Implement SQL-standard LATERAL option for FROM-clause subqueries and function calls
* Allow foreign data wrappers to support writes (inserts/updates/deletes) on foreign tables
* Add a Postgres foreign data wrapper to allow access to other Postgres servers
* Add support for event triggers
* Add optional ability to checksum data pages and report corruption
* Prevent non-key-field row updates from blocking foreign key checks
* Greatly reduce System V shared memory requirements
2013-09-10 15:32:32 +00:00

21 lines
934 B
Text

$NetBSD: patch-src_pl_plperl_GNUmakefile,v 1.1 2013/09/10 15:32:32 adam Exp $
--- src/pl/plperl/GNUmakefile.orig 2013-09-02 20:53:17.000000000 +0000
+++ src/pl/plperl/GNUmakefile
@@ -55,7 +55,6 @@ XSUBPPDIR = $(shell $(PERL) -e 'use List
include $(top_srcdir)/src/Makefile.shlib
-plperl.o: perlchunks.h plperl_opmask.h plperl_helpers.h
plperl_opmask.h: plperl_opmask.pl
@if [ x"$(perl_privlibexp)" = x"" ]; then echo "configure switch --with-perl was not specified."; exit 1; fi
@@ -65,7 +64,7 @@ perlchunks.h: $(PERLCHUNKS)
@if [ x"$(perl_privlibexp)" = x"" ]; then echo "configure switch --with-perl was not specified."; exit 1; fi
$(PERL) $(srcdir)/text2macro.pl --strip='^(\#.*|\s*)$$' $^ > $@
-all: all-lib
+all: perlchunks.h plperl_opmask.h plperl_helpers.h all-lib
SPI.c: SPI.xs plperl_helpers.h
@if [ x"$(perl_privlibexp)" = x"" ]; then echo "configure switch --with-perl was not specified."; exit 1; fi