37a5d3fb3a
use other, better ones from pkgsrc through ncursesw/buildlink3.mk. + Add a configure script that lightly probes the system and write out some system-specific definitions for the Makefile. This should fix PR pkg/29425. + Add necessary includes (<string.h> and <unistd.h>) to global.h to do silly C things like prototype functions before you use them. Remove the unnecessary patches to lots of *.c files that added these same headers. + Include <string.h> in ss.c because it doesn't include global.h. + Move HTML documentation into ${PREFIX}/share/doc. Bump the PKGREVISION to 2.
14 lines
425 B
Text
14 lines
425 B
Text
$NetBSD: patch-ai,v 1.2 2008/02/29 20:53:02 jlam Exp $
|
|
|
|
--- global.h.orig 1996-08-31 04:14:40.000000000 -0400
|
|
+++ global.h
|
|
@@ -20,2 +20,4 @@
|
|
#include <stdio.h>
|
|
+#include <string.h>
|
|
+#include <unistd.h>
|
|
#include "comm.h"
|
|
@@ -72,3 +74,3 @@ typedef struct river {
|
|
pai_t out; /* put pai */
|
|
- attr_t attr; /* attr (how get, how put, how ...)*/
|
|
+ pai_attr_t attr; /* attr (how get, how put, how ...)*/
|
|
struct river *prev;
|