49 lines
2.4 KiB
Text
49 lines
2.4 KiB
Text
$NetBSD: patch-ah,v 1.4 2016/02/28 19:48:17 joerg Exp $
|
|
|
|
--- scribus/CMakeLists.txt.orig 2013-02-26 20:28:44.000000000 +0000
|
|
+++ scribus/CMakeLists.txt
|
|
@@ -641,6 +641,8 @@ SET(SCRIBUS_SOURCES
|
|
vruler.cpp
|
|
)
|
|
|
|
+SET_SOURCE_FILES_PROPERTIES(prefsmanager.cpp PROPERTIES COMPILE_FLAGS "${CLANG_NO_OPT}")
|
|
+
|
|
IF(NOT HAVE_HYPHEN)
|
|
SET(SCRIBUS_SOURCES
|
|
${SCRIBUS_SOURCES}
|
|
@@ -737,13 +739,13 @@ ELSE(WIN32)
|
|
ENDIF(WIN32)
|
|
|
|
##TEST FIX FOR 6897
|
|
-IF (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" OR CMAKE_SYSTEM_NAME STREQUAL "OpenBSD")
|
|
+IF (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" OR CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" OR CMAKE_SYSTEM_NAME STREQUAL "NetBSD")
|
|
# Use the -E / --export-dynamic flag to ensure that symbols in the Scribus
|
|
# binary are in the public symbol table for plugins. The symbols must also
|
|
# be set as SCRIBUS_API if we're building with -fvisibility=hidden .
|
|
# Should fix bug 6897 .
|
|
SET_TARGET_PROPERTIES(${EXE_NAME} PROPERTIES LINK_FLAGS -Wl,-E)
|
|
-ENDIF (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" OR CMAKE_SYSTEM_NAME STREQUAL "OpenBSD")
|
|
+ENDIF (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" OR CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" OR CMAKE_SYSTEM_NAME STREQUAL "NetBSD")
|
|
IF (GCC AND NOT WIN32)
|
|
# Use the -E / --export-dynamic flag to ensure that symbols in the Scribus
|
|
# binary are in the public symbol table for plugins. The symbols must also
|
|
@@ -785,9 +787,9 @@ ENDIF(NOT WIN32 AND NOT HAIKU)
|
|
|
|
# required to resolve symbols from libdl when ld is called with --no-add-needed
|
|
# #9310 for the OpenBSD addition
|
|
-IF(UNIX AND NOT CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" AND NOT HAIKU)
|
|
+IF(UNIX AND NOT CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "NetBSD" AND NOT HAIKU)
|
|
TARGET_LINK_LIBRARIES(${EXE_NAME} dl)
|
|
-ENDIF(UNIX AND NOT CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" AND NOT HAIKU)
|
|
+ENDIF(UNIX AND NOT CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "NetBSD" AND NOT HAIKU)
|
|
|
|
# #9311 for the OpenBSD addition
|
|
IF(CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" OR CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
|
|
@@ -891,6 +893,7 @@ IF(NOT WANT_NOHEADERINSTALL)
|
|
PATTERN "manpages" EXCLUDE
|
|
PATTERN "old" EXCLUDE
|
|
PATTERN ".svn" EXCLUDE
|
|
+ PATTERN "CMakeFiles" EXCLUDE
|
|
)
|
|
ELSE(NOT WANT_NOHEADERINSTALL)
|
|
MESSAGE(STATUS "No source header files will be installed")
|