85b996c375
This includes stub domains support, but it should be considered experimental at this time. Stub domains hangs with serial ports, or more more than one virual disk (multiple virtual ethernet have not been tested).
52 lines
1.6 KiB
Text
52 lines
1.6 KiB
Text
$NetBSD: patch-tools_hotplug_NetBSD_Makefile,v 1.1 2017/03/30 09:15:10 bouyer Exp $
|
|
|
|
--- tools/hotplug/NetBSD/Makefile.orig 2016-02-09 14:44:19.000000000 +0000
|
|
+++ tools/hotplug/NetBSD/Makefile
|
|
@@ -3,12 +3,13 @@ include $(XEN_ROOT)/tools/Rules.mk
|
|
|
|
# Xen script dir and scripts to go there.
|
|
XEN_SCRIPTS =
|
|
+XEN_SCRIPTS += locking.sh
|
|
XEN_SCRIPTS += block
|
|
XEN_SCRIPTS += vif-bridge
|
|
XEN_SCRIPTS += vif-ip
|
|
|
|
XEN_SCRIPT_DATA =
|
|
-XEN_RCD_PROG = rc.d/xencommons rc.d/xendomains rc.d/xen-watchdog rc.d/xendriverdomain
|
|
+#XEN_RCD_PROG = rc.d/xencommons rc.d/xendomains rc.d/xen-watchdog rc.d/xendriverdomain
|
|
|
|
.PHONY: all
|
|
all:
|
|
@@ -21,10 +22,11 @@ install: install-scripts install-rcd
|
|
|
|
.PHONY: install-scripts
|
|
install-scripts:
|
|
- $(INSTALL_DIR) $(DESTDIR)$(XEN_SCRIPT_DIR)
|
|
+ $(INSTALL_DIR) $(DESTDIR)$(XEN_EXAMPLES_DIR)
|
|
+ $(INSTALL_DIR) $(DESTDIR)$(XEN_EXAMPLES_DIR)/scripts
|
|
set -e; for i in $(XEN_SCRIPTS); \
|
|
do \
|
|
- $(INSTALL_PROG) $$i $(DESTDIR)$(XEN_SCRIPT_DIR); \
|
|
+ $(INSTALL_PROG) $$i $(DESTDIR)$(XEN_EXAMPLES_DIR)/scripts; \
|
|
done
|
|
set -e; for i in $(XEN_SCRIPT_DATA); \
|
|
do \
|
|
@@ -33,12 +35,12 @@ install-scripts:
|
|
|
|
.PHONY: install-rcd
|
|
install-rcd:
|
|
- $(INSTALL_DIR) $(DESTDIR)$(INITD_DIR)
|
|
- set -e; for i in $(XEN_RCD_PROG); \
|
|
- do \
|
|
- $(INSTALL_PROG) $$i $(DESTDIR)$(INITD_DIR); \
|
|
- done
|
|
- $(INSTALL_DATA) ../common/hotplugpath.sh $(DESTDIR)$(INITD_DIR)/xen-hotplugpath.sh
|
|
+# $(INSTALL_DIR) $(DESTDIR)$(INITD_DIR)
|
|
+# set -e; for i in $(XEN_RCD_PROG); \
|
|
+# do \
|
|
+# $(INSTALL_PROG) $$i $(DESTDIR)$(INITD_DIR); \
|
|
+# done
|
|
+# $(INSTALL_DATA) ../common/hotplugpath.sh $(DESTDIR)$(INITD_DIR)/xen-hotplugpath.sh
|
|
|
|
.PHONY: clean
|
|
clean:
|