pkgsrc/mail/courier-mta/patches/patch-af
pettai ef568ee609 courier-0.65.0 et al:
* gpglib/list.c: Handle GnuPG 2 --with-colons output format changes.
* gpglib/mimegpgfork.c: GnuPG 2 wants --batch when specifying passphrase-fd.
* tcpd/configure.in: Check if explicit linking with libgpg-error is required.
* tcpd/libcouriergnutls.c (tls_connect): Fix bad call to
  gnutls_server_name_set(). Affects Courier compiled with GnuTLS support.
* maildrop/mailbot.c (main): Set close-on-exec bit on opened files.
* courier/doc/courier.sgml: Move the SPF section to a separate refsect2
  to work around misformatting by the manpage stylesheet.
* rfc2045/rfc2045reply.c (mkreply): Fix sender's name in the reply salutation.
* html/en-us/newmsg.html: Ditto.
* rfc2045/reformime.sgml: Document the -c option to reformime.
* imapd.c (main): Fix typo in alert message.
* Big quota patch (with some changes).

(See the Changelog(s) for previous releases)

Based on patch(es) from PR pkg/42989 by Brian Candler.
2010-06-15 23:01:23 +00:00

14 lines
625 B
Text

$NetBSD: patch-af,v 1.4 2010/06/15 23:01:23 pettai Exp $
--- courier/filters/perlfilter/Makefile.in.orig Sat Jul 21 20:31:15 2007
+++ courier/filters/perlfilter/Makefile.in
@@ -234,7 +234,8 @@ top_srcdir = @top_srcdir@
EXTRA_DIST = perlfilter-wrapper.pl perlfilter-example.pl
BUILT_SOURCES = filtersocketdir.h wrapperpl.h xsinit.c
CLEANFILES = $(BUILT_SOURCES) permissions.dat
-filterbindir = $(libexecdir)/filters
+pkglibexecdir = $(libexecdir)/courier
+filterbindir = $(pkglibexecdir)/filters
filterbin_PROGRAMS = @perlfilter_prog@
scriptdir = $(datadir)
script_SCRIPTS = perlfilter-wrapper.pl perlfilter-example.pl