pkgsrc/lang/ocaml/patches/patch-ai
tron 65fe8e9b94 Fix various issues with this package:
- split patches files
- always enable threading which has various advantages
  - it fixes the build of the Tk library
  - it greatly simplifies the package list handling
  - it provides threading support under NetBSD 1.6/1.6.x
- correct default dependence in "buildlink2.mk" to "build"
Bump package revision because of all these changes.
2004-04-22 09:18:34 +00:00

17 lines
581 B
Text

$NetBSD: patch-ai,v 1.2 2004/04/22 09:18:36 tron Exp $
--- asmrun/i386.S.orig Fri Jun 7 11:49:36 2002
+++ asmrun/i386.S Thu Apr 22 10:34:38 2004
@@ -53,10 +53,10 @@
#elif defined(SYS_bsd_elf)
#define PROFILE_CAML \
pushl %ebp; movl %esp, %ebp; pushl %eax; pushl %ecx; pushl %edx; \
- call .mcount; \
+ call __mcount; \
popl %edx; popl %ecx; popl %eax; popl %ebp
#define PROFILE_C \
- pushl %ebp; movl %esp, %ebp; call .mcount; popl %ebp
+ pushl %ebp; movl %esp, %ebp; call __mcount; popl %ebp
#endif
#else
#define PROFILE_CAML