pkgsrc/wm/wmx/patches/patch-ag
joerg d26cf36e57 - fine grained X11 dependencies for packages which have either USE_IMAKE
or USE_X11BASE set, but don't include mk/x11.buildlink3.mk directly or
  via buildlink3.mks
- introduce BUILDLINK_PREFIX.libXpm as alias for BUILDLINK_PREFIX.xpm
  in the !modular case
- fix some cases where the check for libX11 couldn't work at all by using
  C++ for compilation without including the proper headers

Verified using a full X11_TYPE=xorg bulk build without additional
breakage. Discussed with salo@, wiz@ and send to packages@ for feedback.
2006-12-27 13:37:35 +00:00

16 lines
497 B
Text

$NetBSD: patch-ag,v 1.1 2006/12/27 13:37:42 joerg Exp $
--- configure.orig 2000-05-17 10:53:13.000000000 +0000
+++ configure
@@ -888,9 +888,10 @@ if test "$ac_x_libraries" = NO; then
cat > conftest.$ac_ext <<EOF
#line 890 "configure"
#include "confdefs.h"
+#include <X11/Intrinsic.h>
int main() {
-${x_direct_test_function}()
+${x_direct_test_function}(0)
; return 0; }
EOF
if { (eval echo configure:897: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then