508ca350e2
changes: There are improvements to DVB subtitle support and H.264 video, and fixes for MP3 playback, DVB, ivtv, Flash video streams and some playlist types (particularly XML ones). One significant fix is that the special "be nice to the user" '#' handling has been dropped since it seems to have been causing more problems than it fixes. pkgsrc note: a fix for CVE-2008-0225 (RTSP buffer overflow) is already included
120 lines
4.1 KiB
Text
120 lines
4.1 KiB
Text
$NetBSD: patch-ag,v 1.18 2008/01/11 16:05:27 drochner Exp $
|
|
|
|
--- configure.ac.orig 2008-01-04 19:02:22.000000000 +0100
|
|
+++ configure.ac
|
|
@@ -98,7 +98,7 @@ dnl ------------------------------------
|
|
AC_CANONICAL_HOST
|
|
AC_CANONICAL_BUILD
|
|
|
|
-test "$host" == "$build" && check_athlon=yes
|
|
+test "$host" = "$build" && check_athlon=yes
|
|
|
|
AC_CONFIG_HEADERS([include/configure.h])
|
|
|
|
@@ -555,6 +555,9 @@ AC_CHECK_LIB(socket, socket, NET_LIBS="-
|
|
AC_CHECK_LIB(nsl, gethostbyname, NET_LIBS="-lnsl $NET_LIBS",)
|
|
AC_SUBST(NET_LIBS)
|
|
|
|
+WINE_LIBS=""
|
|
+AC_CHECK_LIB(i386, i386_set_ldt, WINE_LIBS="-li386 $WINE_LIBS",)
|
|
+AC_SUBST(WINE_LIBS)
|
|
|
|
dnl ---------------------------------------------
|
|
dnl socklen_t
|
|
@@ -745,7 +748,7 @@ XXMC_LIBS="-L$xxmc_path -l$xxmc_stub"
|
|
AC_MSG_CHECKING(whether to enable the xxmc plugin with vld extensions)
|
|
AC_MSG_RESULT()
|
|
dnl Check if vld "extended" XvMC is available
|
|
-if test "x$xxmc_stub" == "xXvMCW" && test "x$ac_have_xv" == "xyes"; then
|
|
+if test "x$xxmc_stub" = "xXvMCW" && test "x$ac_have_xv" = "xyes"; then
|
|
AC_CHECK_LIB($xxmc_stub, XvMCPutSlice,
|
|
ac_have_xxmc="yes",
|
|
[ac_have_xxmc="no"
|
|
@@ -775,7 +778,7 @@ if test "x$ac_have_xxmc" = "xyes"; then
|
|
fi
|
|
dnl Try fallback to standard XvMC if vld failed
|
|
if test "x$ac_have_xxmc" = "xno"; then
|
|
- if test "x$xxmc_stub" == "xXvMCW"; then
|
|
+ if test "x$xxmc_stub" = "xXvMCW"; then
|
|
AC_CHECK_LIB($xxmc_stub, XvMCCreateContext,
|
|
ac_have_xxmc="yes",
|
|
[ac_have_xxmc="no"
|
|
@@ -829,7 +832,7 @@ saved_libs="$LIBS"
|
|
XVMC_LIBS="-L$xvmc_path -l$xvmc_stub"
|
|
AC_MSG_CHECKING(whether to enable the xvmc plugin)
|
|
AC_MSG_RESULT()
|
|
-if test "x$xvmc_stub" == "xXvMCW"; then
|
|
+if test "x$xvmc_stub" = "xXvMCW"; then
|
|
AC_CHECK_LIB($xvmc_stub, XvMCCreateContext,
|
|
ac_have_xvmc="yes",
|
|
[ac_have_xvmc="no"
|
|
@@ -920,7 +923,6 @@ if test "x$enable_xinerama" != "xno"; th
|
|
])
|
|
if test "x$ac_have_xinerama" = "xyes"; then
|
|
AC_DEFINE(HAVE_XINERAMA,1,[Define this if you have libXinerama installed])
|
|
- X_LIBS="${X_LIBS} ${XINERAMA_LIBS}"
|
|
fi
|
|
else
|
|
ac_have_xinerama=no
|
|
@@ -1422,8 +1424,21 @@ AC_ARG_ENABLE([oss],
|
|
AS_HELP_STRING([--disable-oss], [Do not build OSS audio output support]))
|
|
|
|
if test "x$enable_oss" != "xno"; then
|
|
+
|
|
+ case "$host" in
|
|
+ *-*-netbsd*|*-*-openbsd*)
|
|
+ OSS_LIBS="-lossaudio"
|
|
+ ;;
|
|
+ *)
|
|
+ OSS_LIBS=""
|
|
+ ;;
|
|
+ esac
|
|
+
|
|
AC_CHECK_HEADERS([sys/soundcard.h machine/soundcard.h soundcard.h], [break])
|
|
AC_CHECK_DECL([SNDCTL_DSP_SETFRAGMENT], [have_ossaudio=yes], [], [
|
|
+ #ifdef __NetBSD__
|
|
+ #include <sys/ioctl.h>
|
|
+ #endif
|
|
#ifdef HAVE_SYS_SOUNDCARD_H
|
|
# include <sys/soundcard.h>
|
|
#endif
|
|
@@ -1439,6 +1454,7 @@ if test "x$enable_oss" != "xno"; then
|
|
fi
|
|
|
|
AM_CONDITIONAL(HAVE_OSS, test "x$have_ossaudio" = "xyes")
|
|
+AC_SUBST(OSS_LIBS)
|
|
|
|
|
|
dnl ---------------------------------------------
|
|
@@ -1548,9 +1564,10 @@ AC_ARG_ENABLE([gnomevfs],
|
|
[with_gnome_vfs=$enableval], [with_gnome_vfs=yes])
|
|
|
|
if test "x$with_gnome_vfs" = "xyes"; then
|
|
- PKG_CHECK_MODULES(GNOME_VFS, gnome-vfs-2.0,
|
|
- no_gnome_vfs=no,
|
|
- no_gnome_vfs=yes)
|
|
+dnl PKG_CHECK_MODULES(GNOME_VFS, gnome-vfs-2.0,
|
|
+dnl no_gnome_vfs=no,
|
|
+dnl no_gnome_vfs=yes)
|
|
+no_gnome_vfs=yes
|
|
AC_SUBST(GNOME_VFS_CFLAGS)
|
|
AC_SUBST(GNOME_VFS_LIBS)
|
|
if test "x$no_gnome_vfs" != "xyes"; then
|
|
@@ -1885,7 +1902,7 @@ int has_timeout=sizeof(test.timeout);]])
|
|
AC_DEFINE([HAVE_WIN32_CDROM], [1],
|
|
[Define 1 if you have MinGW CD-ROM support])
|
|
;;
|
|
- freebsd4.*|kfreebsd*-gnu)
|
|
+ freebsd4.*|kfreebsd*-gnu|dragonfly*)
|
|
AC_DEFINE([HAVE_FREEBSD_CDROM], [1],
|
|
[Define 1 if you have FreeBSD CD-ROM support])
|
|
;;
|
|
@@ -2591,7 +2608,7 @@ case $host in
|
|
dnl FreeBSD (et al.) does not complete linking for shared objects when pthreads
|
|
dnl are requested, as different implementations are present; to avoid problems
|
|
dnl use -Wl,-z,defs only for those platform not behaving this way.
|
|
- *-freebsd*) ;;
|
|
+ *-freebsd* | *-netbsd*) ;;
|
|
*)
|
|
AC_TRY_LDFLAGS([-Wl,-z,defs], [NOUNDEF="-Wl,-z,defs"])
|
|
;;
|