e14a1e0c8b
Joos is an acronym for Java's Object-Oriented Subset. JOOS is a proper subset of Java which is used to teach students about compilers.
28 lines
621 B
Text
28 lines
621 B
Text
$NetBSD: patch-aa,v 1.1 2002/05/08 15:42:02 jschauma Exp $
|
|
|
|
--- A+/Makefile.orig Thu Apr 4 15:19:53 2002
|
|
+++ A+/Makefile Wed May 8 11:25:13 2002
|
|
@@ -1,7 +1,6 @@
|
|
-CC = gcc
|
|
-BISON = bison
|
|
FLEX = flex
|
|
-CFLAGS = -Wall -ansi -pedantic
|
|
+YACC = yacc
|
|
+
|
|
LFLAGS = -lfl
|
|
|
|
OFILES = main.o tree.o error.o memory.o weed.o symbol.o type.o defasn.o \
|
|
@@ -16,11 +15,11 @@
|
|
$(CC) lex.yy.o y.tab.o $(OFILES) $(LFLAGS) -o joos
|
|
|
|
y.tab.c y.tab.h: joos.y
|
|
- $(BISON) -y -d joos.y
|
|
+ $(YACC) -d joos.y
|
|
|
|
lex.yy.c: joos.l y.tab.h
|
|
$(FLEX) joos.l
|
|
|
|
|
|
clean:
|
|
- @rm $(OFILES) joos lex.yy.o y.tab.o
|
|
+ @rm $(OFILES) joos lex.yy.* y.tab.*
|