dba14855c6
PostgreSQL is a robust, next-generation, Object-Relational DBMS (ORDBMS), derived from the Berkeley Postgres database management system. While PostgreSQL retains the powerful object-relational data model, rich data types and easy extensibility of Postgres, it replaces the PostQuel query language with an extended subset of SQL. PostgreSQL is free and the complete source is available. This is the meta-package for the PostgreSQL database system.
31 lines
1.1 KiB
Text
31 lines
1.1 KiB
Text
$NetBSD: patch-ac,v 1.1.1.1 2004/07/24 22:14:40 recht Exp $
|
|
|
|
--- doc/Makefile.orig Wed Nov 27 18:21:20 2002
|
|
+++ doc/Makefile
|
|
@@ -70,7 +70,7 @@ endif # found_man
|
|
|
|
install: all installdirs
|
|
ifdef found_html
|
|
- gzip -d -c postgres.tar.gz | ( cd $(DESTDIR)$(docdir)/html && $(TAR) xf - )
|
|
+ gzip -d -c postgres.tar.gz | ( cd $(DESTDIR)$(htmldir) && $(TAR) xf - )
|
|
endif
|
|
ifdef found_man
|
|
for file in man1/*.1 man$(sqlmansectnum)/*.$(sqlmansect) ; do \
|
|
@@ -81,7 +81,7 @@ endif
|
|
|
|
installdirs:
|
|
ifdef found_html
|
|
- $(mkinstalldirs) $(DESTDIR)$(docdir)/html
|
|
+ $(mkinstalldirs) $(DESTDIR)$(htmldir)
|
|
endif
|
|
ifdef found_man
|
|
$(mkinstalldirs) $(addprefix $(DESTDIR)$(mandir)/man, 1 $(sqlmansectnum))
|
|
@@ -90,7 +90,7 @@ endif
|
|
|
|
uninstall:
|
|
ifdef found_html
|
|
- -rm -f $(addprefix $(DESTDIR)$(docdir)/html/, $(shell gunzip -c $(srcdir)/postgres.tar.gz | tar tf -))
|
|
+ -rm -f $(addprefix $(DESTDIR)$(htmldir)/, $(shell gunzip -c $(srcdir)/postgres.tar.gz | tar tf -))
|
|
endif
|
|
ifdef found_man
|
|
-rm -f $(addprefix $(DESTDIR)$(mandir)/, $(shell gunzip -c $(srcdir)/man.tar.gz | tar tf - | sed -e 's,man$(sqlmansect_dummy)/,man$(sqlmansectnum)/,' -e 's/.$(sqlmansect_dummy)$$/.$(sqlmansect)/'))
|