pkgsrc/devel/nss/patches/patch-an
wiz e09fdcb614 Update to 3.11.4:
The following bugs have been fixed in NSS 3.11.4.

    * Bug 115951: freebl dynamic library is never unloaded by
      libsoftoken or libssl. Also tiny one-time leak in freebl's
      loader.c.
    * Bug 127960: SSL force handshake function should take a timeout.
    * Bug 335454: Unable to find library 'libsoftokn3.sl' on HP-UX 64 bit.
    * Bug 350200: Implement DHMAC based POP (ProofOfPossession).
    * Bug 351482: audit_log_user_message doesn't exist in all
      versions of libaudit.so.0. (the "paranoia patch")
    * Bug 352041: oom [@ CERT_DecodeDERCrlWithFlags] "extended"
      tracked as NULL was dereferenced.
    * Bug 353422: Klocwork bugs in nss/lib/crmf.
    * Bug 353475: Cannot run cmd tools compiled with VC++ 2005.
    * Bug 353572: leak in sftk_OpenCertDB.
    * Bug 353608: NSS_RegisterShutdown may fail, and appData argument
      to callbacks is always NULL.
    * Bug 353749: PowerUpSelf tests update for DSA and ECDSA KAT.
    * Bug 353896: Building tip with NSS_ECC_MORE_THAN_SUITE_B causes
      crashes in all.sh.
    * Bug 353910: memory leak in RNG_RNGInit.
    * Bug 354313: STAN_GetCERTCertificateName leaks "instance" struct.
    * Bug 354384: vfyserv shutdown failure when client auth requested.
    * Bug 354900: Audit modifications, accesses, deletions, and
      additions of cryptographic keys.
    * Bug 355297: Improve the very first RNG_RandomUpdate call.
    * Bug 356073: C_GetTokenInfo should return CKR_CRYPTOKI_NOT_INITIALIZED
      if not initialized.
    * Bug 356309: CertVerifyLog in CERT_VerifyCertificate terminates
      early on expired certs.
    * Bug 357197: OCSP response code fails to match CERTIds. (hot fix only)
    * Bug 359484: FireFox 2 tries to negotiate ECC cipher suites
      using ssl2 client hello. (hot fix only)
    * Bug 360818: No RPATH set for signtool and signver.
2007-01-20 18:55:09 +00:00

32 lines
1.3 KiB
Text

$NetBSD: patch-an,v 1.3 2007/01/20 18:55:09 wiz Exp $
https://bugzilla.mozilla.org/show_bug.cgi?id=323977
https://bugzilla.mozilla.org/attachment.cgi?id=209007&action=view
Added DragonFly.
Also, when building on solaris with gcc, be sure to correctly set the
flags used by the solaris assembler which is explicitly called out in
the makefile in a couple of places. This prevents errors when trying to
assemble files which contain cpu specific instructions.
--- mozilla/security/nss/lib/freebl/Makefile.orig 2006-08-23 22:57:26.000000000 +0000
+++ mozilla/security/nss/lib/freebl/Makefile
@@ -196,6 +196,17 @@ ifeq (,$(filter-out BSD_OS FreeBSD Linux
MKSHLIB += -Wl,-Bsymbolic
endif
+# The blapi functions are defined not only in the freebl shared
+# libraries but also in the shared libraries linked with loader.c
+# (libsoftokn3.so and libssl3.so). We need to use GNU ld's
+# -Bsymbolic option or the equivalent option for other linkers
+# to bind the blapi function references in FREEBLVector vector
+# (ldvector.c) to the blapi functions defined in the freebl
+# shared libraries.
+ifeq (,$(filter-out BSD_OS FreeBSD Linux NetBSD DragonFly, $(OS_TARGET)))
+ MKSHLIB += -Wl,-Bsymbolic
+endif
+
ifeq ($(OS_TARGET),SunOS)
# The -R '$ORIGIN' linker option instructs this library to search for its