pkgsrc/x11/kdelibs2/patches/patch-ag
skrll a62b3e67a6 Update to KDE 2.2.1
With apologies to Al I wouldn't know where to start with a summary of the
changes between 2.1 and 2.2.1 - there are just too many. A couple of
hopefully static URLS that contain useful information are

http://www.kde.org/announcements/changelog2_1to2_2.html
http://www.kde.org/announcements/changelog2_2to2_2_1.html

Support for a.out for kde{libs,base} added by me. The libtool/a.out
combination doesn't like the linking of modules into binaries. A better
way of doing this will appear in future versions of KDE/pkgsrc.
2001-10-15 22:45:55 +00:00

49 lines
1.5 KiB
Text

$NetBSD: patch-ag,v 1.2 2001/10/15 22:46:22 skrll Exp $
--- dcop/Makefile.am.orig Wed Apr 18 17:19:12 2001
+++ dcop/Makefile.am
@@ -25,12 +25,12 @@
KDE_OPTIONS = qtonly
INCLUDES= $(all_includes)
-LDFLAGS = $(all_libraries)
+LDFLAGS = $(all_libraries) $(KDE_RPATH)
bin_PROGRAMS = dcopserver
check_PROGRAMS = testdcop testdcopc
-lib_LTLIBRARIES = libDCOP.la dcopserver.la
+lib_LTLIBRARIES = libDCOP.la libdcopserver_main.la dcopserver.la
libDCOP_la_LIBADD = KDE-ICE/libkICE.la $(LIB_QT)
libDCOP_la_LDFLAGS = -version-info 1:0 $(all_libraries) -no-undefined
@@ -44,13 +44,17 @@
# dcopstub needs to go first for --enable-final to work
libDCOP_la_SOURCES = dcopstub.cpp dcopclient.cpp dcopobject.cpp dcopref.cpp
-dcopserver_la_LDFLAGS = -module -avoid-version
-dcopserver_la_SOURCES = dcopserver.cpp dcopsignals.cpp
-dcopserver_la_LIBADD = libDCOP.la
+#libdcopserver_main_la_LDFLAGS = -export-dynamic
+libdcopserver_main_la_SOURCES = dcopserver.cpp dcopsignals.cpp
+libdcopserver_main_la_LIBADD = libDCOP.la
+
+dcopserver_la_LDFLAGS = -Wl,-export-dynamic -module -avoid-version
+dcopserver_la_SOURCES = dcopserver_main.cpp
+dcopserver_la_LIBADD = libdcopserver_main.la
dcopserver_LDFLAGS = $(KDE_RPATH)
-dcopserver_SOURCES = dummy.cpp
-dcopserver_LDADD = dcopserver.la
+dcopserver_SOURCES = dcopserver_main.cpp
+dcopserver_LDADD = libdcopserver_main.la
testdcop_SOURCES = testdcop.cpp
testdcop_LDADD = ../kdecore/libkdecore.la
@@ -59,6 +63,3 @@
testdcopc_LDADD = KDE-ICE/libkICE.la $(LIBSM)
EXTRA_DIST = HOWTO ICE
-
-dummy.cpp:
- echo > dummy.cpp