Install the man file Approved by: wiz@(maintainer) Upstream changes; pigz version 2.2.5 has been released and is now available at http://zlib.net/pigz/ . The main changes since 2.2.4 are: - Change suffix to .tar when decompressing or listing .tgz. - Print name of executable in error messages. - Show help properly when the name is unpigz or gunzip. - Fix permissions security problem before output is closed. pigz version 2.2.4 has been released and is now available at http://zlib.net/pigz/ . The main changes since 2.2.3 are: - Improve the portability of printing the off_t type - Fix bug in zip (-K) output - Remove thread portability #defines in pigz.c pigz version 2.2.3 is now available at http://zlib.net/pigz/ . The main changes since 2.1.7 are: - Add --rsyncable functionality - Improve thread portability - Fix the printing of 32-bit check values when listing pigz version 2.1.7 is now available at http://zlib.net/pigz/ . The changes from 2.1.6 are: - Avoid unused parameter warning in reenter() - Don't assume 2's complement ints in compress_thread() - Replicate gzip -cdf cat-like behavior - Replicate gzip -- option to suppress option decoding - Test output from make test instead of showing it - Updated pigz.spec to install unpigz, pigz.1 [Obermaier] - Add PIGZ environment variable [Mueller] - Replicate gzip suffix search when decoding or listing - Fix bug in load() to set in_left to zero on end of file - Do not check suffix when input file won't be modified - Decompress to stdout if name is "*cat" [Hayasaka] - Write data descriptor signature to be like Info-ZIP - Update and sort options list in help - Use CC variable for compiler in Makefile - Exit with code 2 if a warning has been issued - Fix thread synchronization problem when tracing - Change macro name MAX to MAX2 to avoid library conflicts - Determine number of processors on HP-UX [Lloyd]
17 lines
410 B
Text
17 lines
410 B
Text
$NetBSD: patch-Makefile,v 1.2 2012/08/05 00:47:45 wen Exp $
|
|
|
|
Honor CFLAGS and LDFLAGS from pkgsrc.
|
|
|
|
--- Makefile.orig 2012-02-12 05:18:18.000000000 +0000
|
|
+++ Makefile
|
|
@@ -1,8 +1,8 @@
|
|
CC=cc
|
|
-CFLAGS=-O3 -Wall -Wextra
|
|
+CFLAGS?=-O3 -Wall -Wextra
|
|
|
|
pigz: pigz.o yarn.o
|
|
- $(CC) -o pigz pigz.o yarn.o -lpthread -lz
|
|
+ $(CC) ${LDFLAGS} -o pigz pigz.o yarn.o -lpthread -lz
|
|
ln -f pigz unpigz
|
|
|
|
pigz.o: pigz.c yarn.h
|