* gpglib/list.c: Handle GnuPG 2 --with-colons output format changes. * gpglib/mimegpgfork.c: GnuPG 2 wants --batch when specifying passphrase-fd. * tcpd/configure.in: Check if explicit linking with libgpg-error is required. * tcpd/libcouriergnutls.c (tls_connect): Fix bad call to gnutls_server_name_set(). Affects Courier compiled with GnuTLS support. * maildrop/mailbot.c (main): Set close-on-exec bit on opened files. * courier/doc/courier.sgml: Move the SPF section to a separate refsect2 to work around misformatting by the manpage stylesheet. * rfc2045/rfc2045reply.c (mkreply): Fix sender's name in the reply salutation. * html/en-us/newmsg.html: Ditto. * rfc2045/reformime.sgml: Document the -c option to reformime. * imapd.c (main): Fix typo in alert message. * Big quota patch (with some changes). (See the Changelog(s) for previous releases) Based on patch(es) from PR pkg/42989 by Brian Candler.
35 lines
1.4 KiB
Text
35 lines
1.4 KiB
Text
$NetBSD: patch-ad,v 1.5 2010/06/15 23:01:23 pettai Exp $
|
|
|
|
--- courier/filters/Makefile.in.orig 2007-11-17 19:49:01.000000000 -0500
|
|
+++ courier/filters/Makefile.in
|
|
@@ -283,11 +283,12 @@ SUBDIRS = libfilter perlfilter
|
|
CLEANFILES = $(htmldoc_DATA) $(man_MANS) filtersocketdir.h filteractivedir.h \
|
|
pidfile.h permissions.dat
|
|
|
|
+pkglibexecdir = $(libexecdir)/courier
|
|
htmldocdir = @datadir@/htmldoc
|
|
htmldoc_DATA = courierfilter.html courierperlfilter.html dupfilter.html
|
|
databindir = $(datadir)
|
|
databin_SCRIPTS = filterctl
|
|
-filterbindir = $(libexecdir)/filters
|
|
+filterbindir = $(pkglibexecdir)/filters
|
|
filtersocketdir = $(localstatedir)/filters
|
|
allfiltersocketdir = $(localstatedir)/allfilters
|
|
filterconfdir = $(sysconfdir)/filters
|
|
@@ -1083,16 +1084,12 @@ install-exec-hook:
|
|
install-data-hook:
|
|
-$(mkinstalldirs) $(DESTDIR)$(filtersocketdir)
|
|
-$(mkinstalldirs) $(DESTDIR)$(allfiltersocketdir)
|
|
- -$(mkinstalldirs) $(DESTDIR)$(filterconfdir)
|
|
- -$(mkinstalldirs) $(DESTDIR)$(filteractivedir)
|
|
-$(mkinstalldirs) $(DESTDIR)$(sbindir)
|
|
chmod 500 $(DESTDIR)$(datadir)/filterctl
|
|
rm -f $(DESTDIR)$(sbindir)/filterctl
|
|
$(LN_S) $(datadir)/filterctl $(DESTDIR)$(sbindir)/filterctl
|
|
chmod 750 $(DESTDIR)$(filtersocketdir)
|
|
chmod 750 $(DESTDIR)$(allfiltersocketdir)
|
|
- chmod 750 $(DESTDIR)$(filterconfdir)
|
|
- chmod 750 $(DESTDIR)$(filteractivedir)
|
|
-chown @mailuser@ $(DESTDIR)$(filtersocketdir) \
|
|
$(DESTDIR)$(allfiltersocketdir) \
|
|
$(DESTDIR)$(filterconfdir) \
|