pkgsrc/emulators/hercules/patches/patch-aa
kristerw a6d25fe153 Bl3ify, and use mk/pthread.buildlink3.mk instead of hard-coding
a pthread package.

Bump PKGREVISION.
2004-05-29 23:32:19 +00:00

52 lines
1.4 KiB
Text

$NetBSD: patch-aa,v 1.6 2004/05/29 23:32:19 kristerw Exp $
Set up compilation flags for NetBSD
--- makefile.orig Sat Feb 10 22:21:58 2001
+++ makefile Tue May 8 18:57:45 2001
@@ -9,5 +9,5 @@
# overridden in the make command line, as in "PREFIX=/foo make install"
# (the directory is only used when installing).
-DESTDIR = $(PREFIX)/usr/bin
+DESTDIR = $(PREFIX)/bin
# Standard flags for all architectures
@@ -22,24 +22,26 @@
# Handle host architecture if specified
ifeq ($(HOST_ARCH),i386)
-CFLAGS += -O3 -malign-double -DNO_ASM_BYTESWAP
-endif
+CFLAGS += -O3 -DNO_ASM_BYTESWAP
+else
ifeq ($(HOST_ARCH),i586)
-CFLAGS += -O3 -malign-double -march=pentium
-endif
+CFLAGS += -O3
+else
ifeq ($(HOST_ARCH),i686)
-CFLAGS += -O3 -malign-double -march=pentiumpro
-endif
+CFLAGS += -O3
+else
ifeq ($(HOST_ARCH),alpha)
CFLAGS += -O2 -DNO_ASM_BYTESWAP
-endif
-ifeq ($(HOST_ARCH),other)
+else
CFLAGS += -O3 -DNO_ASM_BYTESWAP
-endif
+endif # alpha
+endif # i686
+endif # i586
+endif # i386
# Uncomment these lines for NetBSD, with either the unproven-pthreads
# or pth packages
-#CFLAGS += -I/usr/pkg/pthreads/include -I/usr/pkg/include
-#LFLAGS += -L/usr/pkg/pthreads/lib -R/usr/pkg/pthreads
-#LFLAGS += -L/usr/pkg/lib -R/usr/pkg/pthreads/lib
+CFLAGS += -I${PREFIX}/include
+LFLAGS += -L${PREFIX}/lib -R${PREFIX}/lib
+LFLAGS += -L${PREFIX}/lib
# Reverse the comments below to disable Compressed CKD Dasd support