2d6db54b4d
- Link with the C++ compiler because this is written in C++. - Link with all the required libraries to prevent undefined symbols. - Add only libtool libraries to LT_LIBS. Based on patches provided by Ben Collver in PR 34495.
14 lines
459 B
Text
14 lines
459 B
Text
$NetBSD: patch-ac,v 1.3 2006/12/10 23:02:40 minskim Exp $
|
|
|
|
--- spgrove/Makefile.sub.orig 2002-11-15 14:46:50.000000000 -0800
|
|
+++ spgrove/Makefile.sub
|
|
@@ -1,7 +1,8 @@
|
|
LTVERSION=0:1:0
|
|
LIB=ospgrove
|
|
INCLUDE=-I$(srcdir)/../grove
|
|
-DEPLIBS=-lm -L$(TOP)/grove -L$(TOP)/grove/.libs \
|
|
+DEPLIBS=$(TOP)/grove/libogrove.la \
|
|
+ -lm -losp -L$(TOP)/grove -L$(TOP)/grove/.libs \
|
|
-L$(TOP)/lib -L$(TOP)/lib/.libs \
|
|
$(LIB_THREADS)
|
|
OBJS=GroveApp.o GroveBuilder.o SdNode.o
|