abd6bd9b66
* Fix 3581 Ftools: union tool leave holes in output * Fix 4500 Simplify tool freezes QGIS * Fix 4466 Fixes for 'v.what.vect' and 'v.generalize' modules in the GRASS plugin * Fix 4552 Patch for v.what.vect * Fix 4035 Print Composer shape combo box not refecting current shape * Partial Fix 3097 Add preference to set/override environment variables * Fix 2749 Move 'Add to Attributes List' button * Fix 4560 Wrong scale displayed in Map canvas * Partial Fix 4383 Ftools: Improve how processes are handled * Fix 3577 Adding a print composer doesn't dirty the document * Fix 3170 Many GDAL Tools don't work in OS X standalone * Fix 3723 Transparency settings are not applied from *.qml * Fix 3576 qml not read automagically for rasters * Fix 2977 Messy uninstallation of the standalone installer * Union and Symetrical difference works only on whole layer fixed * Save some time in node tool for geometry export and avoid detachs * Initialize default symbol to 0 in rule based renderer * Make relative paths default * Fix tab restoration in project properties * Add helpful info to GdalTools Settings dialog on how to configure GDAL path * New vector layer dialog - show CRS as authid-description pair instead of proj4 string * Fix crash with relative file paths if projPath is not yet defined * Add helpful info to GdalTools Settings dialog on how to configure GDAL path * And a lot of other smaller Bugfixes
20 lines
782 B
Text
20 lines
782 B
Text
$NetBSD: patch-src_app_CMakeLists.txt,v 1.1 2012/01/23 08:58:00 adam Exp $
|
|
|
|
Avoid application bundle on Mac OS X.
|
|
|
|
--- src/app/CMakeLists.txt.orig 2012-01-21 19:36:22.000000000 +0000
|
|
+++ src/app/CMakeLists.txt
|
|
@@ -446,12 +446,7 @@ IF (SPATIALITE_FOUND)
|
|
TARGET_LINK_LIBRARIES (${QGIS_APP_NAME} ${SPATIALITE_LIBRARY})
|
|
ENDIF (SPATIALITE_FOUND)
|
|
|
|
-IF (APPLE)
|
|
- # For Mac OS X, the executable must be at the root of the bundle's executable folder
|
|
- INSTALL(TARGETS ${QGIS_APP_NAME} RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX})
|
|
-ELSE (APPLE)
|
|
- INSTALL(TARGETS ${QGIS_APP_NAME} RUNTIME DESTINATION ${QGIS_BIN_DIR})
|
|
-ENDIF (APPLE)
|
|
+INSTALL(TARGETS ${QGIS_APP_NAME} RUNTIME DESTINATION ${QGIS_BIN_DIR})
|
|
|
|
IF(MSVC)
|
|
INSTALL(FILES qgis.ico DESTINATION ${CMAKE_INSTALL_PREFIX}/icons)
|