pkgsrc/games/xpuyopuyo/patches/patch-Makefile.am
seb b76af8dc62 Update xpuyopuyo to 0.9.8. Changes since the last upstream packaged version 0.9.1:
Changes in v0.9.8:
   *  Correcting a packaging error, and addressing compiler warnings
      that surface in GCC 3.3.

Changes in v0.9.7:
   *  Fixed compiler warnings on Debian, and installer problems.

Changes in v0.9.6:
   *  New theme ``fabo''

Changes in v0.9.5:
   *  Porting some dialog bugfixes in xscorch over to xpuyopuyo
   *  Porting over xscorch's help system into xpuyopuyo
   *  Cleaned up configure script a bit

Changes in v0.9.4:
   *  More verbose error message if theme load fails
   *  Fixed '//' path problem that prevented execution on cygwin

Changes in v0.9.3:
   *  New theme added -- Spheres
   *  Some documentation cleaning

Changes in v0.9.2:
   *  Fixed p_ai_decide() prototype error (spotted by Patrick Markiewicz)
   *  Fixed configure error that was introduced by the stow patch.
   *  Minor correction in network timeout code.
   *  Sound effects implemented, although we're still experimenting with
      the actual effects.  Command-line options
2017-07-02 14:27:25 +00:00

22 lines
826 B
Text

$NetBSD: patch-Makefile.am,v 1.1 2017/07/02 14:27:25 seb Exp $
Fix link by reordering libraries
--- Makefile.am.orig 2003-05-26 16:41:57.000000000 +0000
+++ Makefile.am
@@ -33,13 +33,13 @@ xpuyopuyo_SOURCES=xpuyopuyo.c
INCLUDES=-Ipgame -Ipai -Ipnet
-XPP_LIBS = $(NET_LIBS) pgame/libxpp_game.a pai/libxpp_ai.a
+XPP_LIBS = $(NET_LIBS) pgame/libxpp_game.a # pai/libxpp_ai.a
XPP_NET_LIBS = pnet/libxpp_net.a # This must be after interface
XPP_SOUND_LIBS = $(LIBMIKMOD_LIBS) psound/libxpp_sound.a
if GTK
-xpuyopuyo_LDADD=$(XPP_LIBS) pgtk/libxpp_interface.a $(XPP_NET_LIBS) $(XPP_SOUND_LIBS) $(GTK_LIBS) pgame/libxpp_game.a putil/libxpp_util.a
+xpuyopuyo_LDADD=$(XPP_LIBS) pgtk/libxpp_interface.a pai/libxpp_ai.a $(XPP_SOUND_LIBS) $(GTK_LIBS) pgame/libxpp_game.a $(XPP_NET_LIBS) putil/libxpp_util.a
endif