pkgsrc/devel/glib2/patches/patch-ah
prlw1 5a83cb4ec4 Update glib2 to 2.54.1
glib-genmarshal and glib-menums have been ported to python. To keep
glib2 a python-free zone, these have been moved with gdbus-codegen
to py-glib2-tools.

Packages needing one of those tools to build can include
devel/glib2/buildtools.mk

The licence has been changed from LGPLv2+ to LGPLv2.1+.

A full changelog is available at:
https://git.gnome.org/browse/glib/tree/NEWS?h=2.54.1
2017-10-13 15:35:10 +00:00

24 lines
745 B
Text

$NetBSD: patch-ah,v 1.13 2017/10/13 15:35:10 prlw1 Exp $
Set default search paths for pkgsrc.
--- glib/gutils.c.orig 2017-08-15 20:27:00.000000000 +0000
+++ glib/gutils.c
@@ -2017,7 +2017,7 @@ g_get_system_data_dirs (void)
#ifndef G_OS_WIN32
if (!data_dirs || !data_dirs[0])
- data_dirs = "/usr/local/share/:/usr/share/";
+ data_dirs = PREFIX "/share/";
data_dir_vector = g_strsplit (data_dirs, G_SEARCHPATH_SEPARATOR_S, 0);
#else
@@ -2093,7 +2093,7 @@ g_get_system_config_dirs (void)
}
#else
if (!conf_dirs || !conf_dirs[0])
- conf_dirs = "/etc/xdg";
+ conf_dirs = PKG_SYSCONFDIR "/xdg";
conf_dir_vector = g_strsplit (conf_dirs, G_SEARCHPATH_SEPARATOR_S, 0);
#endif