dac9d0e0d6
This is a bugfix release which fixes over 100 bugs including but not limited to: * Fixed a fatal bug that triggered a panic when your secondary weapon was cursed during bones file creation * Fixed a fatal bug that caused a crash when applying figurine, candle, or bell that gets used up for a complete list, see doc/fixes34.2 Old savegames and bones levels from nethack 3.4.1 (and 3.4.0) should still work, but as usual, caution is advised.
44 lines
1.4 KiB
Text
44 lines
1.4 KiB
Text
$NetBSD: patch-ah,v 1.4 2003/09/02 00:30:57 pooka Exp $
|
|
|
|
--- sys/unix/Makefile.src.orig 2003-08-30 03:08:04.000000000 +0300
|
|
+++ sys/unix/Makefile.src 2003-09-02 03:08:18.000000000 +0300
|
|
@@ -151,8 +151,8 @@
|
|
# flags for debugging:
|
|
# CFLAGS = -g -I../include
|
|
|
|
-CFLAGS = -O -I../include
|
|
-LFLAGS =
|
|
+CFLAGS += -I../include -I${X11BASE}/include
|
|
+LFLAGS = ${LDFLAGS}
|
|
|
|
# The Qt and Be window systems are written in C++, while the rest of
|
|
# NetHack is standard C. If using Qt, uncomment the LINK line here to get
|
|
@@ -214,8 +214,8 @@
|
|
|
|
#
|
|
#
|
|
-WINSRC = $(WINTTYSRC)
|
|
-WINOBJ = $(WINTTYOBJ)
|
|
+WINSRC = $(WINX11SRC)
|
|
+WINOBJ = $(WINX11OBJ)
|
|
|
|
# on some systems the termcap library is in -ltermcap or -lcurses
|
|
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
|
|
@@ -235,7 +235,7 @@
|
|
#
|
|
# libraries for X11
|
|
# If USE_XPM is defined in config.h, you will also need -lXpm here.
|
|
-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
|
|
+WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11 -lXpm
|
|
# WINX11LIB = -lXaw -lXmu -lXt -lX11
|
|
# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
|
|
# WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
|
|
@@ -255,7 +255,7 @@
|
|
# libraries for BeOS
|
|
WINBELIB = -lbe
|
|
|
|
-WINLIB = $(WINTTYLIB)
|
|
+WINLIB = $(WINX11LIB)
|
|
|
|
# any other strange libraries your system needs (for Sysunix only -- the more
|
|
# specialized targets should already be right)
|