pkgsrc/x11/gtkada/patches/patch-docs_Makefile.in
marino caa9280011 x11/gtkada: Update from version 2.22 to 2.24.4
This is the minimum version necessary to build the next version of the
GNAT Programming Studio.  It is also the last version to support GTK2+.
As this will break GPS 5.0, GPS will be imminently upgraded to version
5.2.1 following this commit.
2013-07-09 10:14:53 +00:00

26 lines
892 B
Text

$NetBSD: patch-docs_Makefile.in,v 1.1 2013/07/09 10:14:53 marino Exp $
The gtkada Reference Manual can only be built with GPS which requires
gtkada. This is obviously a circular reference. It would be possible
to split the Reference Manual into a separate package that requires
GPS, but rather than do that, a pregenerated version has been tarballed
as a separate distfile and this patch installs that instead.
--- docs/Makefile.in.orig 2013-07-01 09:42:48.000000000 +0000
+++ docs/Makefile.in
@@ -4,13 +4,12 @@ CP=cp -p
MKDIR=mkdir -p
all::
- ${MAKE} -C gtkada_rm
- ${MAKE} -C gtkada_ug html latexpdf
+ ${MAKE} -C gtkada_ug html
install::
- ${MAKE} -C gtkada_rm install
$(MKDIR) ${DESTDIR}$(docdir)/gtkada_ug/
-$(CP) -r gtkada_ug/_build/html/* ${DESTDIR}$(docdir)/gtkada_ug/
+ $(CP) -r gtkada_rm_pregen/gtkada_rm ${DESTDIR}$(docdir)/
clean::
${MAKE} -C gtkada_rm clean