f999c2f5f4
Fix installation directory of elisp file. Sort PLIST and remove info files entries. Bump PKGREVISION.
26 lines
906 B
Text
26 lines
906 B
Text
$NetBSD: patch-ai,v 1.2 2004/03/09 11:24:04 seb Exp $
|
|
|
|
--- indexer/Makefile.SH.orig Fri Apr 16 11:59:23 1999
|
|
+++ indexer/Makefile.SH Sun May 9 23:14:01 1999
|
|
@@ -56,7 +56,7 @@
|
|
|
|
CFLAGS = $ccflags $optimize -I\$(TOP)/lib/ir $mccflags $embed_cflags
|
|
DPFLAGS = -I\$(TOP)/lib/ir $mccflags $embed_cflags
|
|
-LDFLAGS = -L\$(TOP)/lib -lwais $socketlib -lm $embed_ldopts
|
|
+LDFLAGS = ../lib/libwais.la $socketlib -lm $embed_ldopts
|
|
BIN_EXP = $installbin
|
|
USRINC = $usrinc
|
|
OBJECTS = waisindex.o
|
|
@@ -106,10 +106,10 @@
|
|
waisindex: waisindex.o
|
|
$(RM) $@
|
|
if test -f $@; then $(MV) $@ $@~; else exit 0; fi
|
|
- $(CC) -o $@ waisindex.o $(JLDFLAGS) $(LIBS)
|
|
+ $(LIBTOOL) --tag=CC --mode=link $(CC) -o $@ waisindex.o $(JLDFLAGS) $(LIBS)
|
|
|
|
install:: waisindex
|
|
- $(INSTALL) -c -s -m 555 waisindex $(BIN_EXP)
|
|
+ $(LIBTOOL) --mode=install $(INSTALL) -c -s -m 555 waisindex $(BIN_EXP)
|
|
|
|
deinstall::
|
|
$(RM) $(BIN_EXP)/waisindex
|