6675b59eb1
What's new from release notes: * Improved Junk Mail Controls The algorithm for the adaptive junk mail controls has been heavily redesigned to learn faster and catch more spam. * New Brand Identity To be consistent with the Mozilla Foundation's goal of brand identity, Thunderbird has a new logo and supporting artwork thanks to the fine work of the Mozilla Visual Identity team. * Other New Features... - IMAP users can now benefit from support for the IMAP IDLE command which allows the mail server to push notifications such as new mail arriving as soon as it arrives. - Thunderbird supports server-wide news filters that apply to all newsgroups on a server. - Thunderbird includes Secure Password Authentication using a new cross-platform NTLM authentication mechanism for IMAP, POP3 and SMTP. - Mail filters can now mark messages as junk. - Tools > Options > Compose > HTML Options allows you to set up default HTML compose options such as font, size and color. - Attachments can be opened directly from the compose window to verify their contents before sending. - Thunderbird now supports the notion of multiple identities per mail account. This makes it easy to have several e-mail addresses which end up going into the same account. Read More about how to set this up. * Recently Fixed Bugs - In the case of a failure when copying a message to an online Sent folder, Thunderbird will now ask if you would like it to try again. - Pasting data from an OpenOffice.org spreadsheet no longer pastes random HTML garbage before the actual spreadsheet data into HTML compose. - Fixed several situations where LDAP connections were left open when using LDAP auto complete or performing searches on LDAP directories. - Improved view source behavior. - Mail notification for POP3 messages that are marked deleted or marked read by mail filters no longer occurs. - The "Mark All Read" keyboard shortcut now works for Linux GTK2.
38 lines
1 KiB
Text
38 lines
1 KiB
Text
$NetBSD: patch-ab,v 1.2 2004/05/08 04:35:38 taya Exp $
|
|
|
|
diff -ru ../Orig/mozilla/configure.in ./configure.in
|
|
--- ../Orig/mozilla/configure.in 2004-04-21 10:39:17.000000000 +0900
|
|
+++ ./configure.in 2004-05-05 23:08:54.000000000 +0900
|
|
@@ -1017,6 +1017,9 @@
|
|
# MKSHLIB_FORCE_ALL='-Wl,-Bforcearchive'
|
|
# MKSHLIB_UNFORCE_ALL=''
|
|
# fi
|
|
+ if test "$LIBRUNPATH"; then
|
|
+ DSO_LDOPTS="-Wl,-R$LIBRUNPATH $DSO_LDOPTS"
|
|
+ fi
|
|
;;
|
|
|
|
*-hpux*)
|
|
@@ -1308,6 +1311,13 @@
|
|
if test "$LIBRUNPATH"; then
|
|
DSO_LDOPTS="-Wl,-R$LIBRUNPATH $DSO_LDOPTS"
|
|
fi
|
|
+
|
|
+ case "${target_cpu}" in
|
|
+ alpha*)
|
|
+ CFLAGS="$CFLAGS -mieee"
|
|
+ CXXFLAGS="$CXXFLAGS -mieee"
|
|
+ ;;
|
|
+ esac
|
|
;;
|
|
|
|
*-nto*)
|
|
@@ -1531,7 +1541,7 @@
|
|
MKCSHLIB='$(CC) $(CFLAGS) $(DSO_PIC_FLAGS) -G -Wl,-z -Wl,muldefs -o $@'
|
|
MKSHLIB_FORCE_ALL='-Qoption ld -z,allextract'
|
|
MKSHLIB_UNFORCE_ALL=''
|
|
- DSO_LDOPTS='-G -Qoption ld -z,muldefs -h $@'
|
|
+ DSO_LDOPTS='-G -z muldefs -h $@'
|
|
AR_LIST="$AR t"
|
|
AR_EXTRACT="$AR x"
|
|
AR_DELETE="$AR d"
|