31 lines
1.4 KiB
Text
31 lines
1.4 KiB
Text
$NetBSD: patch-ai,v 1.6 2009/05/16 08:06:57 adam Exp $
|
|
|
|
--- src/tray-monitor/Makefile.in.orig 2008-10-19 12:34:03.000000000 +0200
|
|
+++ src/tray-monitor/Makefile.in
|
|
@@ -45,7 +45,7 @@ all: Makefile bacula-tray-monitor
|
|
|
|
bacula-tray-monitor: Makefile $(MONITOROBJS) ../lib/libbaccfg$(DEFAULT_ARCHIVE_TYPE) ../lib/libbac$(DEFAULT_ARCHIVE_TYPE)
|
|
$(LIBTOOL_LINK) $(CXX) $(LDFLAGS) $(MONITOR_LDFLAGS) -L../lib -o $@ \
|
|
- $(MONITOROBJS) $(DLIB) -lbaccfg -lbac -lm $(LIBS) $(OPENSSL_LIBS)
|
|
+ $(MONITOROBJS) $(DLIB) ../lib/libbaccfg.la ../lib/libbac.la -lm $(LIBS) $(OPENSSL_LIBS)
|
|
|
|
Makefile: $(srcdir)/Makefile.in $(topdir)/config.status
|
|
cd $(topdir) \
|
|
@@ -71,14 +71,14 @@ devclean: realclean
|
|
install: all
|
|
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) bacula-tray-monitor $(DESTDIR)$(sbindir)/bacula-tray-monitor
|
|
@srcconf=tray-monitor.conf; \
|
|
- if test -f ${DESTDIR}${sysconfdir}/$$srcconf; then \
|
|
+ if test -f ${DESTDIR}%%EXAMPLESDIR%%/$$srcconf; then \
|
|
destconf=$$srcconf.new; \
|
|
echo " ==> Found existing $$srcconf, installing new conf file as $$destconf"; \
|
|
else \
|
|
destconf=$$srcconf; \
|
|
fi; \
|
|
- echo "${INSTALL_CONFIG} $$srcconf ${DESTDIR}${sysconfdir}/$$destconf"; \
|
|
- ${INSTALL_CONFIG} $$srcconf ${DESTDIR}${sysconfdir}/$$destconf
|
|
+ echo "${INSTALL_CONFIG} $$srcconf ${DESTDIR}%%EXAMPLESDIR%%/$$destconf"; \
|
|
+ ${INSTALL_CONFIG} $$srcconf ${DESTDIR}%%EXAMPLESDIR%%/$$destconf
|
|
|
|
uninstall:
|
|
(cd $(DESTDIR)$(sbindir); $(RMF) bacula-tray-monitor)
|