pkgsrc/x11/p5-gtk/patches/patch-ab
obache ef6a65954c Fix two issues of graphics/p5-Gdk-Pixbuf suggested in PR 32775.
* should depend on graphics/gdk-pixbuf instead of www/gtkhtml.
* compilation error about a not found gtk/gtktypeutils.h
  (this error didn't break build of the package).

Bump PKGREVISION.
2006-11-08 13:40:33 +00:00

19 lines
641 B
Text

$NetBSD: patch-ab,v 1.1 2006/11/08 13:40:33 obache Exp $
--- ../GdkPixbuf/Makefile.PL.orig 2003-06-17 09:47:56.000000000 +0000
+++ ../GdkPixbuf/Makefile.PL
@@ -9,8 +9,12 @@ $gpb = new ExtUtils::Depends('Gtk::Gdk::
mkdir('build', 0777);
-$gpb->set_inc (`gdk-pixbuf-config --cflags`);
-$gpb->set_libs (`gdk-pixbuf-config --libs`);
+$libs = `gdk-pixbuf-config --libs`;
+$inc = `gdk-pixbuf-config --cflags`;
+$libs =~ s/\s+/ /g;
+$inc =~ s/\s+/ /g;
+$gpb->set_inc ($inc);
+$gpb->set_libs ($libs);
$gpb->add_typemaps (cwd() . '/pkg.typemap', cwd().'/build/GdkPixbufTypemap');
$gpb->add_headers (qw( <gdk-pixbuf/gdk-pixbuf-loader.h> ));