pkgsrc/databases/mysql-cluster/patches/patch-storage_heap_CMakeLists.txt
jnemeth 7697633caf MySQL Cluster is a highly scalable, real-time, ACID-compliant
transactional database, combining 99.999% availability with the
low TCO of open source.

Designed around a distributed, multi-master architecture with no
single point of failure, MySQL Cluster scales horizontally on
commodity hardware to serve read and write intensive workloads,
accessed via SQL and NoSQL interfaces.
2014-12-01 05:57:48 +00:00

16 lines
700 B
Text

$NetBSD: patch-storage_heap_CMakeLists.txt,v 1.1.1.1 2014/12/01 05:58:03 jnemeth Exp $
Build with newer DTrace.
--- storage/heap/CMakeLists.txt.orig 2013-11-17 18:02:53.000000000 +0000
+++ storage/heap/CMakeLists.txt
@@ -22,7 +22,8 @@ SET(HEAP_SOURCES _check.c _rectest.c hp
hp_rename.c hp_rfirst.c hp_rkey.c hp_rlast.c hp_rnext.c hp_rprev.c
hp_rrnd.c hp_rsame.c hp_scan.c hp_static.c hp_update.c hp_write.c)
-MYSQL_ADD_PLUGIN(heap ${HEAP_SOURCES} STORAGE_ENGINE MANDATORY RECOMPILE_FOR_EMBEDDED)
+MYSQL_ADD_PLUGIN(heap ${HEAP_SOURCES} STORAGE_ENGINE MANDATORY
+ RECOMPILE_FOR_EMBEDDED DTRACE_INSTRUMENTED)
IF(WITH_UNIT_TESTS)
ADD_EXECUTABLE(hp_test1 hp_test1.c)