This is a copy of the previous lang/erlang of that release, with a few bits tidied up, and configured to live alongside the newer lang/erlang package by using a versioned library directory. This version is required for at least databases/couchdb, and may be required for other software that is incompatible with OTP 23.
15 lines
419 B
Text
15 lines
419 B
Text
$NetBSD: patch-erts_configure.in,v 1.1 2021/01/27 16:13:51 jperkin Exp $
|
|
|
|
Fix linker flags on SunOS.
|
|
|
|
--- erts/configure.in.orig 2018-09-11 14:57:05.000000000 +0000
|
|
+++ erts/configure.in
|
|
@@ -3031,7 +3031,7 @@ case $host_os in
|
|
DED_LD_FLAG_RUNTIME_LIBRARY_PATH=
|
|
;;
|
|
solaris2*|sysv4*)
|
|
- DED_LDFLAGS="-G"
|
|
+ DED_LDFLAGS="-shared"
|
|
if test X${enable_m64_build} = Xyes; then
|
|
DED_LDFLAGS="-64 $DED_LDFLAGS"
|
|
fi
|